Before my phone was said to be rooted by root checkers, I tried many rooting apps, both Android and PC based.

The first significant change which happened occurred when I first installed and used the app called 360Root. 360Root seemed to install an outdated su binary in my system. After that, Root Validator tells me "Root Denied", rather than the usual "Root Unavailable". I tried to update su binary in SuperSU by chainfire, but the installation failed again. After multiple attempts to update the binary,

I thought I should try a PC program called KingoRoot. I used it after downloading and installing it. Kingoroot ran and completed successfully, but checking it in Root Validator still says "Root Denied". I tried again, and it still said sucesss. This time, some, but not all apps that require root like Busybox recognized my device as rooted, so I am able to install BusyBox applets. Kingo Superuser disabled SuperSU, although SuperSU still didn't work that time because su binary is just not updated.

Then I've tried again KingRoot, which succeeded in taking over the root from Kingo. I checked the root status in Root Validator. It now looks like a good news to me, because it tells me "Root is available". However, after opening some root required apps, they still don't recognize my device as rooted.

So finally, I had tried to replace KingUser with SuperSU by downloading terminal emulator first and then the "how-to-replace-kinguser-with-supersu.zip" file. I've followed the instructions perfectly, and it did replace it after updating the su binary and making SuperSU a system app. All the root checkers say that my phone is fully rooted. But, the apps that require root are still saying that I don't have root. Until then, I've noticed that there is a fifth line in Root Validator which says, "SELinux is enforcing". I downloaded a SELinux mode changer which can change SELinux modes from enforcing to permissive and vice versa. Even after changing that and rebooting, the apps still did not work. What could be the possible solution for apps not recognizing that I am rooted? Am I officially rooted? Is this condition have something to do with KitKat's improved security?

TL;DR: Root apps succeeded, and root checkers all say that I am rooted. However, apps that need root are denied root. SuperSU is installed.

  • 2
    That was quite a wall of text only few would climb, Rukiko. Special thanks to PoisonNinja for making it readable! (Friendly hint: please take this lesson in formatting – it drastically increases your chances to good answers). – Izzy Jul 21 '15 at 19:54
  • 1
    Is the permission for su binary correct? I tend to think that if the Root Validator says that your device is rooted yet is not asking for permissions to access su, then it probably is looking for su's presence. Tell me what are the file permissions for su binary? – Firelord Jul 22 '15 at 10:49
  • SuperSU already doesn't warn me about updating su binary 'cause I think it's already updated and I can fully navigate through the options and menus of SuperSU. What I believe is that my android isn't officially rooted 'cause it's just rooted by one click rooting programs & apps. What I seem to accept as customs to rooting especially on a Samsung unit are the usage of Odin program (flash tool) & Odin download mode to install roms and the flashing of certain downloaded zip files at the recovery mode to update the android's system. – Rukino Jinsen Jul 22 '15 at 13:09
  • Did you flashed a custom recovery? If so, then try to flash a flashable supersu zip. This is best way in rooting I have ever got. – Vivek Ji Dec 22 '15 at 5:16
  • KingRoot makes a terrible mess, and is probably the cause of the problem. Having used several other root apps on the same firmware doesn't help. I'd reflash the firmware and start over. – Michael Hampton Apr 24 '16 at 6:05
  • Go to SuperSu/Superuser(Or whatever app you have)

  • If app that doesnt got root access are listed there try giving it root access always.

For SuperSU Its like: SuperSU > Apps > (App for which root access is denied) > (Select GRANT) in Access

  • I've changed it from prompt to granted now. Then I tried to open one of my root required apps but it still don't recognized my rooted android device. Thanks for the advice as an answer but it didn't solve the problem. Sorry... – Rukino Jinsen Jul 21 '15 at 17:14
  • I will try to update answer as soon as I will find another solution. – Ash-Ishh.. Jul 21 '15 at 17:45
  • 1
    @RukinoJinsen While waiting for other hints, take a look at our logging tag-wiki. Logs might give you a clue what's going on. Also, you could check whether next to the super-user app there's also a su binary available (SuperSU includes the featue to update it, which is another thing you could try). An one more thing to check: SuperSU has a log section. Are there any entries? Does the app section list any app? – Izzy Jul 21 '15 at 19:58

This can happen in many cases.

  1. Your device could not get rooted properly at first.

  2. Some sort of settings in your SU/SuperSU/superuser app has been altered, which shows unexpected root behavior.

  3. Your device has become unroot, due to some activity you performed after rooting.

In all the cases above, convenient solution will be to perform a complete root procedure again. And do not alter any internal root settings, unless you know what you are doing.

Also, use and update only the SU app that was installed while rooting. I personally prefer SUPERSU BY CHAINFIRE.

Clean the SuperSU app's Data in settings/Applications and try Again. It worked for me.

protected by Community Nov 15 '15 at 19:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.