0

Whenever I try to download an app from Google Play Store, it allows me to accept the App Conditions but I don't see it downloading. A sign that shows there's an error pops up, 'Error retrieving information from server. [RPC:S-7:AEC-0 ZVSF-VF44-KHLR]'.

What should I do? Please help. I need to download an app.

0

Goto Settings > Apps > All > Clear Cache and Data for these apps > Play store, Download manager and Google Services framework.

Remove you google account from your Account > Google section under your phone Settings.

Reboot your device and add your google account back and then try to download/update the apps from the Playstore.

  • 1
    Might or might not solve it. According to Error while buying apps in Google Play store in Android Jelly Bean (raising the very same error code) it could also be the attached credit card has expired ;) But yes: that's the "generic fall-back" to most errors with GPlay ;) – Izzy Jul 22 '15 at 13:14
  • Yes i agree but the OP hasn't mentioned he is buying/downloading a paid app. So I just posted a generic first aid solution which solved the problem for many. Other reasons also include corrupted sdcard, credit card expiry. etc. :) – Lucky Jul 22 '15 at 13:22
  • Agreed, Lucky. I just found that relation by using our search on the error code. And mentioned it just in case – it might "ring a bell" with the OP (or other readers), saving them from "unnecessary work" :) – Izzy Jul 22 '15 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.