Here's one that's been driving me crazy: The other day, I noticed songs on my phone's "Thumbs Up" playlist, songs that were both bought from Google Play or from elsewhere, were greyed out on my phone.

This seems to be a problem with Google auto-matching songs to their own songs offered on the Play Store. The songs that are greyed out and were uploaded have an option to "Fix Incorrect Match", but songs that were purchased from Google are greyed out anyway. Songs that can't be matched are left alone. This is also only limited to the "Thumbs-Up" playlist.

Songs that can't be matched are not greyed out.

(Click the image for full-size)

This issue does not persist on Windows and does persist on Android regardless of internet connectivity or playlist downloading.

  • ? DRM not being honored consistently between the music apps on the different devices?
    – wbogacz
    Commented Jul 23, 2015 at 19:06
  • I don't think it's a DRM issue. Some of the greyed out songs are songs I've actually purchased from Google. In fact, EVERY greyed out song in the picture is from Google except for Thriller, which I uploaded myself from the This Is It album, ripped myself way back when I used iTunes. Commented Jul 23, 2015 at 19:09
  • Maybe a silly thought, but on my phone the songs are only greyed out if I'm offline. Only songs that are available offline are not greyed out. Maybe try to select "downloaded only" in your menu and see if they disappear completely. This would also explain why the songs are still available on your PC.
    – pgruetter
    Commented Jul 29, 2015 at 19:05
  • As you can see, "Downloaded Only" is not turned on, and even though I appear to have no or very little signal, the songs would not be greyed out. Commented Aug 5, 2015 at 17:15

4 Answers 4


I managed to fix it by checking my settings, "stream only on wifi" was turned on some how.. once I turned that off, everything available as before


It's actually quite simple. Those songs aren't available because you have no internet connection, and Google never cached them on your phone for offline music.

To test this out, try this: Connect to WiFi, and you'll notice that all your songs are available. Try playing a song all the way through. Now turn off WiFi/your data connection and you'll notice you can still play that particular song, while others might be grayed out.

Note: This also happens for songs on a data connection as well when the "Stream on WiFi Only" toggle is checked.


Oddly enough, this fixed itself on it's own.

Fix it, Felix!

(Click the image for full-size)

Thanks for nothing, Google.

  • 1
    It probably is about license issues
    – SarpSTA
    Commented Jan 19, 2016 at 21:02
  • It may be due to the device thinking it is offline as the grayed out portion is that of songs not in Cache or songs not downloaded for offline listening Commented Feb 21, 2016 at 6:27

I had this issue. I force stopped the app and cleared the cache. All good now.

  • This fixed the problem for me on my S7. I did a Clean All from Smart Manager, then force stopped Google Play Music from Applications -> Application Manager. Commented Aug 22, 2016 at 15:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .