0

I got an old HTC Wildfire S from someone, without a SIM card, but I won't need one since I'll only be using this for testing purposes. Now the first thing I did was give it a hard reset to get rid of all his old stuff, his Google account etc.
Maybe I shouldn't have. Or maybe I should have backed up everything first. So it's really my fault. Anyway, this is what I have now.

  • The home screen is black. There's nothing on it, no background image, no icons, nothing
  • There is no keyboard. Tapping in a text field does nothing
  • In Settings, many items give the error "The application Settings (process com.android.settings) has stopped unexpectedly"
  • I can't connect to my Wifi, because the WPS button doesn't do anything. (And I can't type in the password to my modem manually, because there is no keyboard to type on.)
  • Restart > Recovery no longer works properly; this does the same as a normal Restart instead of booting into the Recovery console

So, does anybody recognise these problems, and do you have any idea what I can do about them?

  • 1
    Have you tried to get to the bootloader? Power off the device. Wait for it to fully power off. Then hold down volume and press the power button. If you can get to the bootloader, You should be able to get to the stock recovery and try a factory reset that way. Use the volume keys to move through the menu, use the power button to enter the selected option. But worst case scenario, if a factory reset doesnt fix all of the above problems you were talking about, you can download a custom rom and go through the process of unlocking the bootloader, installing a custom recovery.... continued... – jer3my Jul 24 '15 at 8:53
  • Then install a custom rom or a stock rom. It's been awhile since I used an HTC device and I know your device is a bit older but you might be able to still find the RUU for your device. HTC calls factory images "RUU's" and that should return your phone to 100% stock, like when it came out of the box. – jer3my Jul 24 '15 at 8:53
  • Pressing Volume Down on start causes the "loading" icon to appear for a very long time (several minutes; I was afraid it wasn't going to do anything else), after which it ends up in the same black home screen, except it now says "safe mode". Wanted to try again, but then it wouldn't shut down any more (the shutdown menu appears when pressing the power button, but tapping the choices does nothing). Removed the battery to switch it off, but after retrying I have the same result. – Mr Lister Jul 24 '15 at 9:29
  • Considering the bullet points you mentioned that are plaguing you (even after factory reset (hard-reset is different thing)), I suggest you save yourself the trouble and flash the stock ROM. – Firelord Jul 24 '15 at 11:36
  • And that's what I did manage to do in the end. Couldn't get the connection to the PC working, but fortunately my PC has an SD card reader, so I could download a new system to the SD card and and then put it in the phone again. Problem solved. – Mr Lister Jul 24 '15 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.