Because of my external SD card issue, I thought I should factory reset my phone then reinstall the firmware on it. Before I'd do that though, I'd have to back up my apps and their data so that I can restore it afterwards. For that purpose, I had been relying on Titanium Backup Pro, so I entered the app, changed the backup directory to /storage/emulated/legacy/TitaniumBackup (as the external SD card was unavailable) and attempted to backup all user apps and system data. A progress dialogue appeared and was stuck at 0% for about 30 seconds until it close and Titanium Backup displayed the notification 'Batch backup interrupted: Insufficient free storage space' despite having 7 gigabytes left on /storage/emulated/legacy.

I tried searching on Google for a solution - the only one that came up was to remove /data/app/com.keramidas.TitaniumBackup-1.odex but the file did not exist on my end. How can I fix this issue?

Clarification: My copy of Titanium Backup is a Pro version activated by a Pro key obtained from the Google Play store. There is no need for any external patchers, cracks or keygens.

  • This may sound trivial let alone odd but did you consider removing SD card from the device and restarting the latter? Your SD card issue wasn't straightforward, the card was visible to root (which means to apps running as root as well) but not to others.
    – Firelord
    Commented Jul 24, 2015 at 11:06
  • that odex file couldn't exist in that path ,only if you odexed that titanium yourself ,that file is located in /data/dalvic-cache/arm/data@[email protected] Commented Jul 24, 2015 at 11:12
  • @Firelord I have tried restarting the device with the card removed, but that didn't solve the issue. I'm getting the same error from Titanium Backup.
    – Arielle
    Commented Jul 24, 2015 at 11:20
  • @Arielle have you tryed uninstalling and then reinstalling ? Commented Jul 24, 2015 at 11:25
  • @lord-ralf-adolf I have just tried that, and it still doesn't work.
    – Arielle
    Commented Jul 24, 2015 at 11:33

11 Answers 11


This is due to the 'Mount namespace separation' setting in SuperSU being turned on (by default). Untick that, reboot and try your Titanium Backup operation again.

This happens because the permissions to app-created folders are restricted in newer Android versions, I believe. Ironically, I didn't have this issue on Marshmallow-based CM13, but I did face it in the Lollipop-based OxygenOS for the OnePlus One.

  • This works like a charm on my Lollipop 5.1.1 based DU ROM for HTC One m7, thanks!
    – number5
    Commented Mar 6, 2016 at 16:34
  • Worked for me as well. I had missed backups for weeks thinking I really was out of space. Commented May 14, 2016 at 13:03
  • Thank you very much! This works for me on Kitkat 4.4.2. It's stupid of SuperSU to silently introduce this, as it entirely disables some other apps without warning, and without any hint about the cause. Or is it really Titanium's fault?
    – Cerberus
    Commented May 28, 2016 at 17:35
  • @Cerberus It's Google's fault :-)
    – aalaap
    Commented Jun 15, 2016 at 5:29
  • 1
    Where is the option to disable name space separation? CM 12.1 doesn't use SuperSU.
    – Celeritas
    Commented Oct 1, 2016 at 2:21

This happens due to some service change in kitkat. Some research on google showed that there is an app available to modify the platform.xml file. The app once run, prompts the user to allow it to go ahead and make the modifications to the above file. Everything works fine after this.

NextApp SDFix


At TB's startup it always displayed a warning that SuperSU's namespace separation feature "might not work reliably on some platforms".

Well, I never faced any problems until a recent SuperSU update...

So disabling that option in SuperSU and rebooting solved the "insufficient space" on my OnePlus One/CM12.1.

This was the obvious solution before fiddling around with permissions etc.


In recent versions of Android, paths under /storage/emulated/legacy only work for the apps that created them. If the OS doesn't know that TB created /storage/emulated/legacy/TitaniumBackup, then you'll get this error.

Try using TB to create a directory, then use that for your backups. Alternatively, use a path that doesn't start with /storage/emulated/legacy, like /data/media/0/TitaniumBackup. Either should work.

  • Either should work... but neither did. I tried creating another directory on /storage/emulated/legacy, and using that for the backups - didn't work. I tried using a path that did not start with /storage/emulated/legacy - /mnt/sdcard (/data was not accessible to Titanium Backup at all) and it still didn't work as intended.
    – Arielle
    Commented Jul 25, 2015 at 9:11
  • Hmm, I know I solved this exact problem on my TF700T after installing a new ROM. But I had similar issues in a number of apps. I must have used the /data trick in a different one. I assume you used TB to create the other directory in /storage/emulated/legacy? Won't work otherwise. Commented Jul 25, 2015 at 10:09

(Titanium Backup)batch backup interrupted: insufficient storage space this solution work for me any one can try see if it work. I have a fix. I did a little research and found that you can edit /etc/permissions/platform.xml and add a group to WRITE_EXTERNAL_STORAGE


Add the media_rw group:

Done. Doing a TiBU right now to my external card. This may fix other apps that have issues writing to the card, I personally didn't find any.

Suggest that you do an adb pull of the file for safekeeping before doing this. If you pull the file, edit it, and push it back make sure the permissions are set to 644.

  • I didn't have this group on Android 6, but had it on Android 5. Just adding it fixed the insufficient storage space message for me. So add this above the "WRITE_MEDIA_STORAGE" entry: <permission name="android.permission.WRITE_EXTERNAL_STORAGE" > <group gid="sdcard_r" /> <group gid="sdcard_rw" /> <group gid="media_rw" /> </permission> Commented Jan 7, 2017 at 7:04

just go to super user-settings-untick "mount namespace separation" and reboot done!!

  • 4
    And the reasoning behind it?
    – Firelord
    Commented Jan 6, 2016 at 20:36
  • Same answer as highest rated. Titanium Backup now pops a warning if Namespace separation is enabled, which separates the superuser commands in some way. Titanium backup can't access the right things if namespaces are separated.
    – mix3d
    Commented Mar 9, 2016 at 19:20

If you are using Magisk as your superuser manager, go to settings > mount namespace mode and select isolated namespace. Hope this helps someone!

  • 1
    Unfortunately, this did not really help. At the end, I set mount-namespace-mode to "global namespace" in Magisk and selected "DocumentProvider storage" in Titatium backup settings and there the correct folder on the external SA card. This combination seem sto work.
    – jherb
    Commented Jul 14, 2020 at 16:22

As @Izzy said, this was an XY problem - I could have looked for another backup solution instead of insisting on using Titanium Backup. And I did - I used the adb backup feature (which worked when I rebooted my phone). In the end, I didn't have to restore the backup at all, but that's a different story altogether.


Open Preferences of your Titanium Backup. Then look for an option called Backup app external data in Backup Settings. Make sure it is NOT Enabled. Rather set it to 'Enabled if smaller than a chosen size' and set the size to 35 MB.

(Click image to enlarge)

IMG: Backup external data

Some apps have a hefty amount of external data (stored in /sdcard/Android/data), particularly games which may span over several gigs. This option disables backing them up as they can be downloaded again.

  • Sorry, but that solution didn't really work on my end. 'Backup app external data' was already set to 'Enabled if it's smaller than a chosen size' and the size was set to 32 MB, so I tried setting it to 'Disabled (Always)' and retrying the backup... which didn't work.
    – Arielle
    Commented Jul 24, 2015 at 17:41
  • @Arielle Try turning on Compression (setting it to BZIP2). Make sure you're just backing up the user apps and NOT any system apps. Commented Jul 25, 2015 at 4:00
  • I tried changing Compression from GZIP to BZIP2, and backing up the user apps only. Still doesn't work. Even though I have 7 GB of space left.
    – Arielle
    Commented Jul 25, 2015 at 7:25
  • Last resort: Run logcat as root. It will give you an idea at least. Commented Jul 25, 2015 at 13:28

Go into Titanium Backup settings

  • Backup Folder location
  • Storage provider
  • Select "DocumentProvider storage"
  • Allow access to ____



I have also faced this weird situation. I don't know whether it will work or not. But for me it works.

Install lucky patcher. It will automatically remove the odex file and you will be able to install Titanium Backup.

  • But there doesn't seem to be any .odex file. And it doesn't seem to be hidden considering its tutorials around the web. // And TitaniumBackup is already installed!
    – Firelord
    Commented Jul 24, 2015 at 11:12
  • In my case same scenario is there. I also not able to view the file. Please install this apk and open . just wait for 5-10 sec it will automatically scan and remove. You will se a notification when its done
    – Dalvik
    Commented Jul 24, 2015 at 11:13
  • android.stackexchange.com/questions/105816/… see my question
    – Dalvik
    Commented Jul 24, 2015 at 11:15
  • there is not odex file ,only if you odex the app your self ,like applying a patch from lucky patcher ,if you do lucky patcher will apply patch to an odex file and put it in the same directory as the apk (I think the use of lucky patcher is illegal -just saying- ) Commented Jul 24, 2015 at 11:15
  • 1
    @Dalvik Thanks for the help but you're missing the basic point. We can't seem to find that odex file and that patcher is certainly no magical thingie which would create that file on its own, delete it, and then tell us that it did the job! Right!
    – Firelord
    Commented Jul 24, 2015 at 11:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .