1

I have a Motorola Moto G (2nd Gen/2014) phone. I have set up a mobile hot spot, and when I activate it, my laptop can connect to it. I can ping the gateway, so the wifi connection between phone and laptop is working. On the phone I can browse and check mail, etc, so the phone's mobile data connection is working. But I cannot use the internet from the laptop. It's not a DNS issue, because I can't even ping my work server by its IP, nor some common DNS servers like google's or OpenDNS.

Has anyone else had this problem, and if so is there a solution or workaround?

EDIT: after doing further digging, it seems only IPv6 forwarding is being enabled, and of course without root you can't enable it.

1

I faced the very same issue with MOTO E, MOto G2, 3 and Now with 4. everything works fine if i use Bluetooth tethering or USB tethering. as soon as i connect my Laptop with WiFi of the G4 (WiFi threatening option) it connects but shows a yellow mark over Wifi.

I tried every single trick available over Internet but nothing worked. finally i did a small change and everything became fine. what i did is as follows:

click on wifi symbol and go to the available networks--> find the network of your hotspot and right click--> go to connection properties --> change encryption type to "AES" if already selected go to advance setting--> click over check box (enable FIPS compliance)--> click ok --> click OK again and you are good to go.

i tried this on windows 8, things must be more or less same for windows 7 and 10.

  • Hi, I've since flashed my Moto G2 with cyanogenmod so I can no longer confirm this answer works. Hotspot works just fine now by the way. Thanks for the answer though. – sirlark Oct 11 '16 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.