10

Is there any option to get rid of those not useful, permament notifications on Android 5.1, in particular App permission management is running

They are just taking space and focus, are not helpful to the user at all.

Lock screen screenshot

Edit: please note that I'm asking about the notification messages, not the icons.

  • 1
    You can disable the notifications for individual apps if you hold the notification and tap the bell icon. – Firelord Jul 26 '15 at 9:30
  • 1
    @Firelord that didn't work for me, there's no bell icon for the "App permission management..." notification – isalgueiro Oct 14 '15 at 20:32
1

I am sorry to say that it is not possible without root access.

If you do have root access, then there are a number of options. One simple method which I have used in the past is an app called "Notifications Off" from the Play Store. Another more advanced option is to use GravityBox via the Xposed framework.

But care needs to be taken. You can only choose between all or nothing for a given app. Therefore it is only safe to disabled the App Permission Management notifications if you have Permission Management switched off, otherwise you will miss all the dialog boxes which occur when an app requests a permission, causing many apps to be completely unusable.

  • causing many apps to be completely unusable So the simple answer is that it is impossible to have notifications without at least one (per app) permament notification displayed? – Sfisioza Nov 15 '15 at 13:02
  • @Sfisioza it shouldn't be quite like that. It is only one App Permission Management notification which we are stuck with, and that is only if you choose to have it enabled. If you disable app permission management then you can dismiss the notification once after power up and it won't return until next reboot – Mark Ch Nov 15 '15 at 13:11
  • There is ways you can turn of the notification. – maks112v Jan 8 '16 at 13:49
  • @maksim112 oh really? HOW? tell me i am curious.. – Jaxx0rr Jul 12 '16 at 11:11
0

The easiest way to fix this is to block the notification from showing. There are two ways to fix this.

First method

  • Go to your notification and long press the persistent notification.
  • Tap ! mark on the right side. That will take you to Settings
  • Select Block and turn it on.

Second method

  • Go to Settings → Apps
  • Select the app with the persistent notification
  • On the same screen select Notifications
  • Select Block and turn it on.
  • 2
    Yeah great block all notifications from the App permission management app and then dont get notified when an app needs to be granted permission, so you cant grant it. Great idea. – Mark Ch Jan 8 '16 at 14:31
  • Well you choose if you want the notification or not – maks112v Jan 8 '16 at 14:36
  • 1
    The detail is... We want to retain the pop up notifications which occur as part of the Permission Management app, but just not the one permanent one which is stuck there all the time. There doesnt seem to be a way to distinguish – Mark Ch Jan 8 '16 at 14:38
  • Nonetheless, a vote up for the shortcut to notification settings. Didnt know that. – Mark Ch Jan 8 '16 at 14:39
  • You can block both or non – maks112v Jan 8 '16 at 14:39
0

Go to Settings -> Security -> Disable "App permissions" under Device administration section.

  • -1 this isn't what the OP asked for. – geotheory Jun 8 '16 at 15:35
  • I had to turn it on first. Then turn it off. – Maor Hadad Jun 14 '16 at 15:56
0

Click on it until it changes to an android face and permission control text with an (i). Click on the (i) and disable it. Click on the app and force stop.

I think it does the trick.

-1

Actually Yes,You can do it some Apps that are available in PlayStore the app i came across is 360 Security it has an option to stack all your system notifications using Notification Manager Still it puts up an permanent Notification where you can see your unwanted notification Its better to have 1 notification compared to several occupying your Notification panel :)

-1

Follow these instructions:

  1. Launch Settings app → "Sound & notification".
  2. Under "Notification" go to the entry "App notifications". You can search for application you want to block, open it, switch the "Block" button and you are done.
  • that application is not there – user151496 May 18 '16 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.