0

I've got a fairly new Lenovo A7600-F, which has updated to Android 5 since I purchased it. I'm also fairly new to Android, having gotten my first device (Galaxy S4) five months ago. I wouldn't call myself a power user.

Because I write on my tablet, and on my home computer (Kubuntu 14.04.2 LTS, kept up to date), I searched for a method to directly edit the ODT files from LibreOffice on the tablet, and found AndrOpen Office. Aside from font availability limitations, this has been working pretty well, except for one thing: when I connect the tablet to my computer, I can only access files on the SD card, and then only write to a single folder (LOST.DIR), and files stored there open in AndrOpen Office Writer as read-only, even after formatting the SD card in the tablet. I've tried moving the AndrOpen Office app to SD storage, and that failed, but Android gave no indication (that I've seen) why. Opening a document from internal storage and using "Save As" to put it on the SD card also fails; though I didn't note the exact error message, it said something about "nonexistent object" and "nonexistent file".

I'm able to install other apps directly to SD card when I've selected the SD card as primary write location via Settings. I'm able to copy files to and from the SD card using the File Browser that came pre-installed on the tablet (I'm not sure if this is part of Android or something Lenovo installed; my phone is a Verizon device, and they modify the OS a good bit, making it uncertain to compare built-in apps between phone and tablet). This makes me confident the SD card isn't mounted in read-only mode.

How can I save documents from AndrOpen Office directly to the SD card, or open documents from the SD card in editable form (i.e. to save back to the original file)?

  • I've got no Lollipop to check and confirm, but with Kitkat Android was messed up concerning SDcard completely (apps only had read access), which on Lollipop was rather "worked around" instead of being fixed: apps need to be specifically prepared to work with the new API if they want write to SD. My guess is AndrOpen is not prepared for that. If that's the case, you'll have to contact the devs. – Izzy Jul 26 '15 at 17:47
  • I haven't had problems saving to SD with my phone (even before it upgraded to Lollipop) -- but I haven't tried to run AndrOpen Office on it. – Zeiss Ikon Jul 27 '15 at 11:11
0

Go to 'Other cloud storage' and your external sd card will be listed there, somewhere on the bottom left. Navigate to the document and you will be able to open ït in read/write mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.