7

My device is a Sony Xperia Z and it's running Android 5.0.2. It prompted me to update my Google Play Services, and when I followed the notification it delegated me to the Play Store to update it. However it would seem it is already updated.

My current version of Google Play Services is 7.8.93.

(Click image to enlarge)

screenshot

The notification keeps coming back and I can't seem to find a solution. How do I get rid of this notification permanently?

Here's a look at the notification :

(Click image to enlarge)

Screen Shot 2

7
  • I see this quite often. In my case, it always helped to 1) switch back to the list of your apps, then 2) tap the app to update again (in very rare cases, repeat 1+2 again). This usually makes the "Open" button turn into "Update". Does that work for you? On the other hand, if just this app is affected: it usually auto-updates itself, so it might be you're just not fast enough :) Check which version is installed now, and then check again after the next update pops in (updates are quite frequent here).
    – Izzy
    Jul 27, 2015 at 10:02
  • 1
    When you refer to "list of your apps" do you mean going to the play store and then navigating to the my apps tab? If so Google Play Services is not listed. Jul 27, 2015 at 10:08
  • Yes, that's what I meant. Didn't check for play services there yet as I had no need, but neither did I get any update notifications for it: that app just updates itself without asking me – which is why I suggested checking the version numbers (in Settings › Apps › All).
    – Izzy
    Jul 27, 2015 at 10:24
  • OK. Check again when your issue happens the next time. I bet it then already has updated itself – so your issue would be "how to get rid of those useless notifications". Please verify, and then edit your question accordingly (also include the Android version running on your device then).
    – Izzy
    Jul 27, 2015 at 10:33
  • It's a simple notification. Unlock the screen, go to notification bar, tap and hold that notification and choose a bell icon with a slanted line on it.
    – Firelord
    Jul 27, 2015 at 16:35

3 Answers 3

1

Settings > Apps > Google Play Services > Notification settings > off

Settings > Apps > Google Play Store > Notification settings > off

That's it.

1
  • Since the question body also mentioned "How do I get rid of this notification permanently?", this answered that question, though as the OP has commented before, "That could work but only hides the problem".
    – Andrew T.
    Jan 4, 2023 at 20:08
0

Each time I have reset my phone, exactly the same thing happens. I cannot update individually only Google Play Services as it goes into an infinite loop of popups saying that you cannot Update until you Update.

The solution which worked every time is to go to the Google Play Store into the Apps and Games (sometimes called differently depending on the version) and doing a Update All. Obviously, it may update more than you want but that is the only reliable way that worked on Android 7.0. Hopefully, this can work (or some similar steps) for your version too.

-1

No 'guru' here, running LG tablet w/Android v5.0.2, updated software yesterday and was unable to 'update' Play Services, altho I was constantly reminded to do so. Finally, for some reason, I decided to move Play Services App button to a different location and, when I did, it updated automatically and (I hope!) OK. Notification is gone.

2
  • 2
    That's nonsense :D
    – PeerNet
    Sep 11, 2017 at 5:01
  • I think you're likely confusing coincidence with causality. Jul 16, 2022 at 19:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .