6

I've see this question asked a lot, but I haven't seen any real answers.

I'm getting the low application data space error, but I have 440MB/750MB free on my internal storage.

With more than 50% free how can I be low on space? Is there any solution to this other than deleting things? It seems that the error goes away at around 460MB free, but it's ridiculous that I would have to maintain that much free space to now be "low".

Any thoughts on what I can do about this?

1
  • 1
    Have you tried any of the suggestions listed here?
    – gary
    Commented Jul 21, 2011 at 20:58

2 Answers 2

3

This error is not just for the total storage, it is also for specific "mount points" like /data/data, for example, where the applications on the device store their data. If this mount point becomes low on space, because it is not given access to "all the storage", then you will receive that low space message. You can uninstall apps that you no longer need/use or go in to the Settings -> Applications -> Manage Applications and clear the data for apps that are using a lot, or you don't use often.

5
  • Thanks for this. Also, Cachemate for Root can clear the cache for some apps with the tap of a button. appbrain.com/app/cachemate-for-root-users/com.aac.cachemate
    – Malachi
    Commented Jul 21, 2011 at 16:26
  • yes, but I didn't mention that because it requires root. 99% of users are unrooted. but if you have root, its a great app. Commented Jul 21, 2011 at 17:04
  • 99% are sadly missing out...
    – Adam
    Commented Jul 22, 2011 at 16:44
  • Thanks Ryan. Is there a way I can tell which one it's complaining about? When I run the mount command there are around 20 or so mount points. Many of them seem to be for the data of specific apps.
    – Tom Kiley
    Commented Jul 23, 2011 at 18:08
  • If you have root you can run the command line program "df" to get a list of mount locations, blocks used, blocks available, and used percent. You may also be able to do this with the SDK tools without root, I am not sure.
    – Malachi
    Commented Oct 24, 2011 at 20:57
-1

Occurred only after Android 2.3.4 update for me. I Tried clearing cache for Facebook, Gmail, Internet - worked, but only temporarily.

The only thing that worked was factory reset. I didn't want to do it, but now phone is running well, even with increased battery life.

All paid apps will be saved. Use Verizon backup to back up your contacts before you reset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .