A couple of days ago, I got an error on my phone (Motorola Razr HD xt925) saying that it cannot load the home screen. So, I restarted it in order to resolve the issue. However, it didn't reboot and since then it has been stuck in the Motorola logo.

  • I tried to do recovery or factory reset, but all the options lead to the same Motorola logo with no luck.
  • The only option that is working is AP Fastboot. I managed to unlock the bootloader by getting an unlock code from Motorola's website and using the mfastboot command. So I assume that the fastboot command is working since it detects the devices; however, I couldn't make ADB command to work since it give the error: 'device not found'.
  • Anyway, the second step is to flash the phone. According to this question, I should be able to do that. However, when I am running the command fastboot flash partition gpt.bin, I am getting the following result:

    (bootloader) Variable not supported!
    target max-download-size: 30MB
    sending 'partition' (32 KB)...
    OKAY [  0.022s]
    writing 'partition'...
    FAILED (remote failure)
    finished. total time: 0.154s

I have been searching for days to solve this problem, but nothing yet! I don't know which part I am doing wrong.

  • I just want to verify that there nothing else in the command prompt and the word error was not present followed by a reason? Another issue is when at the Motorola website the mfastboot command was use. At the second step running the command fastboot flash partition gpt.bin is that correct? What was the file name of the mfastboot software and where did you get it? What type of PC are you using? did you set a path? Which command prompt did you use? Did you run it with elevated privileges? Oh and what version of android did you have before the crash? That s
    – Bo Lawson
    Aug 2, 2015 at 5:15
  • 1) Have you made sure that this - low battery is not the case? 2) Is the bootloader unlocked? 3) Could you consider flashing only a custom recovery using fastboot? We can then flash a zip file from Recovery mode.
    – Firelord
    Aug 2, 2015 at 13:25
  • @BoLawson: mfastboot is same as fastboot but for Motorola phone. I found it at xda-developers.com and also at sbf.droid-developers.org. I have tried both on Windows and Linux machines with elevated privileges. The android version was originally v4.0.4 (Ice Cream Sandwich) but I had upgraded it to v4.4.2 (KitKat) using OTA.
    – Sina
    Aug 2, 2015 at 17:13
  • @Firelord: 1) Yes. 2) Yes. 3) How should I do that? Sorry for asking, but I am a newbie here!
    – Sina
    Aug 2, 2015 at 17:13
  • 1
    (bootloader) unlocked: yes (bootloader) iswarrantyvoid: yes
    – Sina
    Aug 2, 2015 at 17:59

3 Answers 3


Use Motorola root toolkit. From here, give a try to mfastboot-v2, then post your results.

  • the tool kit is not working on my windows 10
    – user181519
    Aug 6, 2016 at 22:41

This step is not necessary just leave it and continue other steps if more steps fails then you should use your lastly updated ROM version... You can't flash lollipop ROM on marshmallow bootloader...flash stock marshmallow ROM or your current rom using mfastboot v2...😈😈😈😈


The Remote failure is simply causing for flashing an old/incompatible gpt.bin file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .