1

When trying to connect to my Nexus 5 (5.1.1) in Android Studio (1.0.1) my device is not found. I am running Windows 8.1 Pro.

In the [SDK]/platform-tools directory I ran the command:

adb devices

which returned:

List of devices attached

(Empty list)

I have tried several ways:

I have no problems with accessing files on my Nexus through my computer. The nexus also is shown as "Nexus 5" in Device manager and not some other driver.

But I am still not able to connect to the phone with Android Studio and ADB command won't list the device.

How can I get it listed?

Related links:

1

One thing I noticed not mentioned in what you have tried that will make your device invisible. Have you enabled USB debugging on your Nexus 5. USB debugging helps operating systems communicate with each other and without it things get lost in translation. To enable USB debugging

  1. Go into Android settings menu and scroll down to the about phone menu next go towards the bottom and hit the build number 7 times. settings/about phone/build number

  2. This will reveal a new menu within the main Android settings called developers options and scrolled to USB debugging and enable it.

That should get you up and running but if not then scrap the the driver you modified. Go to SDK redownload Google drivers and install them. That issue was reported in 2013 and the drivers in SDK have been updated since.

  • That USB Debugging being enabled part is mentioned in the related links (in questions). If OP was reading patiently then he would have definitely seen it and then enabled it in the phone. – Firelord Jul 30 '15 at 11:29
  • Actually shamefully I hadn't missed it in the other threads, I believed that I had activated it by enabling Developer options. Changing the language to english and then checking the Developer options again solved it for me. – Anthony H Jul 30 '15 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.