The things I did to update firmware from Android 4.4.4 to 5.0.2:

  1. Installed latest Samsung usb drivers for mobiles
  2. Installed latest Samsung kies and through that I installed device drivers.
  3. Downloaded Odin v3.10.6.
  4. Put my phone in odin mode.
  5. Connected my phone to my pc via original usb cable.
  6. ODIN -> AP -> lollipop firmware (G360FXXU1BOD9_G360FOXA1BOD9_G360FXXU1BOD9_HOME.tar.md5) -> start.

After that this happened;

enter image description here
enter image description here

And my device showed this error in red color : SECURE CHECK FAIL : aboot.

Any suggestions, how can I get 5.0.2 lollipop on my core prime?

Edit : I recently put phone to format, then removed micro SD, and then did everything from step 4 but no luck. It's a new Samsung Galaxy Core Prime SM-G360F (nearly 5 days old).

  • Are you sure that the ROM you downloaded isn't corrupt? You can test to see if a file is corrupt by comparing its md5 signature to the one on the server. Ask the ROM uploader if they can help.
    – galexite
    Jul 30, 2015 at 17:34
  • 1
    Otherwise, it may be that the boot loader is utterly incompatible with your phone. You can't just put ROMs from other Samsung phones in to ODIN and think that it will work if that is the case.
    – galexite
    Jul 30, 2015 at 17:36
  • @georgeunix no that is not the case, The name of the file clearly shows that. Also I (just to ensure) extracted the .tar.md5 file using 7z in some folder and the file got extracted without any errors. Jul 30, 2015 at 17:39
  • I don't know what model number the Galaxy Prime is ;)
    – galexite
    Jul 30, 2015 at 17:41
  • Are you sure your boot loader is unlocked?
    – galexite
    Jul 30, 2015 at 17:41

4 Answers 4


This indicates that you are using the wrong file for your phone model.

  • Not sure why this got downvoted, as I am :), and I know people will say OMG don't do that, but Tmobile and International Variants can be interchanged, I've done it many times. But ODIN is stopping me. Aug 18, 2016 at 0:56

I used to get the same message. Then I removed an option called "sécurité Verr. de réactivation" in french. Translation may be "Reactivation Lock Security". Uncheck it and restart root procedure.


I have an imperfect solution!

If you can still get into your recovery module (TWRP in my case), then you can use a micro-sd card to flash a rom onto the device. In my case, I used CM 12 because I knew it would work, and I was freaking out, panicking that i had bricked it completely.

My experience was with a Galaxy Note 4 on T-Mobile. Hope this helps.

However, I am by no means an expert, so there is likely a better way.

  • I tried that too, btw I got it fixed by technician in 5 min who had original copy of the firmware. I don't know which answer to pick as right one. Jan 31, 2017 at 15:08

If you are sure that your download file is complete, remove .md5 by renaming it. Try flashing afterwards, it wont calculate the checksum then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .