2

I have been reading a bunch of articles on ways to fix this "red light" issue. My issue seems a bit different from most articles as the red light does not show up when I plug in my charger. Articles I have read seems like most "red light" appears when they have the charger plugged, but my issue is that the red light only shows up when I have my charger plugged AND holding down the power button for several seconds. Without holding down the power/power+volume down button, the red light doesn't blink at all.

What I have tried:

  • Unscrewing the two screws for the battery, as some article has stated it was a design flaw where the screws tighten causes the battery connector to not work.
  • Replaced battery with a new one, nothing different, still unresponsive phone.
  • Left charger plugged into phone for 24 hours, phone does not get warm/hot so I doubt the charger is even charging the phone. (no red light)
  • Used Qi wireless charger, phone got really warm but still nothing.

If anyone had this issue and solved it, please inform me on how you did so. I'm not sure if it is a battery issue or some other component but would like to get to the bottom of this. Before this happened, my phone was being charged using a car charger and I noticed the charger was loose so the charging indicator kept blinking on and off rapidly. I believe that may have drained the battery to 0% but I did replace the battery with a new one and issue was not fixed. Hope the seller didn't send me a dead battery as well.

1

I am having the same problem, with no red light when charging a nexus 4. I changed the usb cable and it charged.

The problem came back however. I just noticed that if I held down the buttons while inserting the cable, the red light came back on.

After a while, it started blinking, and charged fully.

I use my nexus4 for development, so it is on for days even weeks in a row, which is not good for the battery.

Also most computer usb sockets dont provide half the current that a dedicated usb charger does, and that is what flattened the battery.

It would be nice if I could bypass the battery completely, since this one is always tethered to the workstation.

0

My experience is that it happens, if the batteries are old and they are completely depleted. Probably somehow the characteristics of such batteries changes so, that the power of the system can't handle it. With load batteries it would work, even if they are old.

You can power on a Nexus4 with no batteries, purely from USB, but it will be very unstable and will power off after some seconds. This is another modus what its power system can't handle.

Now the problem is, that typically only the Nexus4 can load a battery. If the methods of @DominicCerisano's excellent answer don't work, you might try to re-charge the battery without the device, roughly so ( https://www.youtube.com/watch?v=EIazSD44WKc ). This video doesn't show a battery re-charge without the phone, but a battery test. But external recharge works on the same way (instead of the measurement unit, use a simple power source. Avoid reverse polarity!)

In general, if your batteries aren't very good, use a dedicated charger without a PC. Most PC motherboards are incapable to give the required power. There are many differences in quality even in the dedicated chargers; you can play with them by experience. Even some usb cable can harm the charging, particularly the thin ones.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.