0

Just last night I was moving apps to my SD card and the phone (Sony Xperia Z1) randomly restarted. When it came back up, all the apps on my SD card no longer worked. Their icons became generic with a tiny SD card in the bottom corner.

When I tap an app, I get the message "Application not found". I've tried un-mounting and removing the SD card, restarting, clearing cache, but nothing works.

When I go to the App Store, the apps show up as if they need to be installed but when I look at the SD card via my PC, all the files are there still. The pictures and videos are still accessible from the phone however. Before that, I had problems moving a game to the SD card. I kept getting a "Not enough memory" error, even though all the other movable apps moved and I deleted apps to make space.

I tried options I found on the forums and other websites but to no avail, and the only thing I haven't done yet is to root my phone, which I am trying to avoid.

0

Maybe I can help with part of your question. I too have had a 'Not Enough Space' issue. I deleted a bunch of files and off-loaded more, still I could not move or edit other files. Going to settings and checking 'Device' 'Storage' the operating system indicated that I had over 2/3 of my internal memory available.

I found that if I power cycled the device it would reset the file space available counter in another part of the operating system. I also found that I could not count on my deletions or moves being deleted or moved unless I used the Power Cycle trick very soon after preforming the deletions or moves.

0

I think this is probably the fault of the SD card, not Android. It sounds to me like your SD card is corrupted.

I had a somewhat similar problem once, but not exactly the same. Every once in a while icons for all image files I put on the external micro SD card would change from thumbnails to gray squares with black keyholes, and the files would become inaccessible. I was able to open other files I had stored, and new image files I put on the SD card were okay at first, but later turned into the unopenable keyhole icons. Then I started getting error messages claiming I was out of memory when only a fraction of the space was used. I reformatted the card and tried copying some images to it. The error messages about being out of memory were gone, but a couple of weeks later the images became inaccessible again, with the gray keyhole icons.

The solution was to throw the SD card in the trash and get a new one. I haven't seen these problems again in the year and a half since then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.