6

My Nexus 6 is unable to start the camera. The google camera app hangs when it starts and nothing shows up. Earlier the camera used to open but it lagged a bit when HDR was on. Now the camera isn't opening anymore. The other apps like Instagram that use the camera are also not able to open it. The app opens up and hangs, nothing shows up just black screen and sometimes the message "Can't connect to Camera" appears. This issue came after 5.1 and I also had buzz launcher installed once but then I removed it. The phone is less than 7 months old.

What I've tried:

  1. Forced stop the app (Google Camera)
  2. Cleared cache of the app
  3. Booted in recovery mode and wiped cache partition
  4. Factory reset the device

Nothing worked for me, I tried these steps one by one and then tested the camera but it is still not working. Please help me with this, I paid a lot of money for this phone on my own and it feels really bad and annoying that the camera isn't functional anymore.

Thanks in advance.

Update: after no solution was found and no help from Motorola, Google or flipkart, I have sent the phone for repair to the service center.

  • 1
    I'm not surprised that you see this issue on Google Camera, but my issue on CM12 tends to be resolved by a reboot. Yours is odd because it persists even after factory reset. – Firelord Aug 2 '15 at 22:18
  • Yes it is. I have almost tried everything but I think its deeply related to the hardware, idk. If anyone can help me, please do. Thanks. – Robot Boy Aug 3 '15 at 5:50
  • If you search just "Can't connect to Camera" you quickly realize that it is a common problem not only on Nexus 6, but on Nexus 5 too and even Nexus 4. Maybe there is some fundamental problem with camera interface in these devices. So you are not alone. Use your warranty. – jis Aug 6 '15 at 16:12
  • Yes as @Firelord said, A restart of the camera app or the reboot phone always worked in my Moto G2. Have you tried any third party camera apps or whatsapp camera? – Lucky Aug 6 '15 at 16:31
  • Yes I have tried everything. Whatsapp, instagram both. Restarted the phone several times after the problem occurred. Nothing worked. – Robot Boy Aug 6 '15 at 16:39
1

The phone is back from the service center and it works fine again. They told me that they had to replace the camera unit. It took them more than 2 weeks to get this done though. The people there were not aware of the actual reason for the issue to occur, neither were they concerned. But I'm happy that it works now.

1

I am nto sure why or how this worked:

I had the same issues described here - cannot connect to camera. at one point i just gave up.

then a different issue started: my battery was draining fast. the blame was on the media service (something like that). so i went to apps, found Media Storage, Stop, clean cache, reboot.

battery issue fixed. suddenly i noticed, camera issue fixed as well!

0

This is a common issue with some Android devices, but each of them have different reasons for acting up, of course. When I had my Nexus 5 about two years ago, this happened to me. I brought it for a diagnosis to my repair guy. He immediately knew that it was a hardware problem, opened the phone and did his thing and re-wired. It may be a literal wire connection problem with the camera to the phone. I'm not sure of the literal technical terms, I don't repair phones. I suggest using your warranty or try getting a diagnosis and get it repaired, whatever you'd prefer.

  • 1
    Seems to be the only option right now. Weekend is ruined, I guess. – Robot Boy Aug 7 '15 at 2:18
0

Go to Settings – Developer options — find “Use NuPlayer” and uncheck . (If you can’t find the Developer options, go to Settings — About phone — Touch “Build number” 7 times to enable the Developer option)

  • I forgot to mention but I did that as well and then restarted the phone, but it did not work. – Robot Boy Aug 15 '15 at 8:17
  • oh.. This happened with me just today with yuphoria and doing above solved it.. Maybe one of the reasons why CM is said to be better than android.. Happy independence day anyways! – anshabhi Aug 15 '15 at 9:38
-1

My nexus 4 did same thing, I found these instructions on the internet and they worked perfectly, I emailed them to myself so I could see them on my laptop and followed them on the Nexus 4 and they worked perfectly, you might want to try them: I wish I had saved the name of the originator so I could give them credit, but have lost the site: WIPING THE CACHE PARTITION

If your phone is on, turn it off.Press & hold the Volume Down and then press & hold the Power button simultaneously until the phone turns on. You'll see the word "Start" with an arrow drawn around it.Press the Volume Down button twice to highlight Recovery mode.Press the Power button to start Recovery mode. You'll see an image of an Android robot with a red exclamation mark.While holding the Power button, TAP the Volume Up button until a menu appears. 6.Use the volume buttons to scroll to "wipe cache partition" and press the Power button to select it.

Note: This process can take up to 10+ minutes to complete.

permalinkembedparent

[–][deleted] 2 points 8 months ago

It worked: THANK YOU!

  • OP has already tried this and it didn't work for him. Read 3rd point in What I've tried – Manubhargav Sep 22 '15 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.