I am using Huawei Honor 3C running v4.4.2, and is rooted for like 1 year without any issue. All of a sudden I am receiving this error: "Check your connection and try again" on Play Store.

Every time I connect to internet it gives me "Unfortunately, Google Play Services has stopped" error 1-2 times and then it goes away.

Possible solutions I already tried:

  1. Changing time to/from Automatic/Manual
  2. Removing 'hosts' file
  3. Airplane mode On/Off
  4. Force stopping and clearing data/cache of Play Store and Google Play Services app
  5. Uninstalling updates
  6. Removing and adding the Google account again
  7. Changing DNS to Google's or Open DNS' DNS in WIFI setting
  8. Setting 'No Proxy' in Wi-Fi setting
  9. Changing IP Address (incrementing)
  10. Resetting all apps settings to default

On Device:

  • Hangout and other apps are working fine
  • Using latest version of Google Play Store and Google Play Services
  • I am unable to find Service Framework app
  • 1
    When "removing hosts file" do you mean taking the junk out of it, or deleting the file completely?
    – Dan Brown
    Commented Aug 4, 2015 at 11:17
  • Did both. First removed the ad filters (junk?) from it and then removed the file.
    – Alam
    Commented Aug 4, 2015 at 12:07
  • always keep the file, no benefit (Long term) comes from removing the hosts file.
    – Dan Brown
    Commented Aug 4, 2015 at 13:18
  • I only deleted it because deleting the file solved the issue for some guys.
    – Alam
    Commented Aug 4, 2015 at 23:15
  • Bizarre much? Anyway, I found it does not help too often.
    – Dan Brown
    Commented Aug 5, 2015 at 10:30

4 Answers 4


I saw that you've all required steps but just check if Google Service Framework is deactivated - normally in the end of the app list or in a tab called "Deactivated" (Settings>Apps>All). Google Framework Services is a must to have in android so that you can update the apps and make connections with Google Servers.

Also reset app preferences (Settings>APPS>(Phone Menu) Reset App Defaults)

  • Google Services Framework app is not deactivated. After resetting every app to default I see a new error 'unfortunately the process com.google.process.gapps has stopped' for 1-2 times and then the error changed to 'Unfortunately, Google Play Services has stopped'.
    – Alam
    Commented Aug 23, 2015 at 20:06
  • Seems that Play Store / Play Services can't make the update. Try to make the login with other account or create other account to force connection. Also ty to make login in hangouts at least 4 times to force the connection and check if it works
    – loonix
    Commented Aug 25, 2015 at 10:25

Happened to me long time ago and I solved the problem uninstalling Play Services and reinstalling again. In my case I downloaded from Apkmirror an older version and then it asked to update. I did it and everything worked perfectly.

BUT be sure sure which version you need because it depends on your processor and Android version. There's an explanation about this on Apkmirror when you go to download the Play Services apk.

Hope it helps!


Getting a Google Services Framework apk from MIUI forum, installing it, clearing the cache/data of Google Play Services and Google Play Store, and in the end, restarting the phone solved the problem for me. It seems that the Services Framework was the culprit.

Thank you everyone who answered or helped me.


For everyone that used the latest version of Lucky patcher and Play Store Proxy:

You may encounter that when you uninstalled the proxy, the legit Play store would say this. In that case, use the standard iptables flush rules. It doesn't really use the hosts file.

Use a terminal emulator or ADB to flush your iptables' tables. Does not work with Freedom.

iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .