2

I have done the follwoing to silence the camera :

  1. Renaming the files in system/media/audio/ui/
  2. Adding this line to system/csc/others.xml <CscFeature_Camera_ShutterSoundMenu>true</CscFeature_Camera_ShutterSoundMenu> and setting to true <CscFeature_Camera_EnableCameraDuringCall>true</CscFeature_Camera_EnableCameraDuringCall>

  3. Checking if <ShutterSound> was set to off in system/csc/customer.xml

  4. Adding ro.camera.sound.forced=0 to /system/local.prop and /system/build.prop

Steps 1 and 2 were the only things that worked. I now have a silent camera for the photo mode (even the autofocus sound I gone!) BUT I still have the autofocus sound when I am on the video mode. The Shutter Sound option doesn't appear in the menu when I am on the video camera mode, but it does when I am on the photo mode.

Any idea how I can add the Shutter Sound menu entry to the Setting menu for the video mode of the stock camera app?

I am aware that disabling the camera sound is illegal in some part of the world.

Edit: using Tasker to switch to silent mode when the app is open is not an option.

  • I need clarification here. Do you hear that sound if the device is in Silent mode or Vibration mode? Because if that's the case, then you can use Tasker to put the phone in vibration or silent mode when the Camera app is launched, and revert back to settings when the app is closed. I can post an answer possibly but I need confirmation. – Firelord Aug 4 '15 at 18:18
  • I hear this sound when I am on vibrating but not on silent mode however, using Tasker is not a solution for me (I forgot to add this in the question, see the update !). Thanks for your help Firelord! – MagTun Feb 8 '16 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.