0

I have an HTC desire 820s running on Kitkat 4.4.4.

I have set phone storage as my default write disk in Settings. However, when I open ES file explorer, I always find that many folders named like ucbrowser, whatsapp, blackmart etc., have been created in my external card. Even when I delete them all and check after sometime, I find that they have been recreated.

Can you tell me how to stop these folders from getting created? I want them to be created in my internal SD card, not in external SD card.

bumped to the homepage by Community 17 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

1

In KitKat by default, non-system apps (for example Es file manager) cannot make changes to the external SD card outside of their data directory due to security policies.

To get around this issue, you can use your device's built in file manager to manage the external SD card.

If your device doesn't have a system file manager, you'll have to root the device to give Es full access to your storage.

0

Application storage location setting (internal or external SD card) in Android system settings involves location of application's private files such as databases or preferences. These files cannot be accessed by user unless the user has root privileges.

Application may create additional folders on it's own on your external SD card and nothing can be done about that from the perspective of the system. This is your case. The only thing is to check settings inside the app itself that could offer to disable saving of additional data.

I'm not 100% percent sure what you mean by "i have set phone storage as my default write disk" since as far as I know there is no system wide setting for default application storage location. If you edit your question I may provide additional info in my answer.

  • "i have set phone storage as my default write disk" . I guess that means Settings -> Storage -> default write disk -> Internal storage – Spikatrix Aug 6 '15 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.