-1

I had a personal folder created in the root directory in Android (when you connect Android to windows, the directory that opens up). I copied a bunch of files and folders. It all went well. Then I disconnected the phone and I could access this folder from it.

However, later whenever I re-connected my phone to Windows, that particular folder did not show up in Windows explorer. I can still see it in File Manager. So it's definitely present. It contains some images and i can view those too. It's not hidden or system file. Yet it doesn't show up in Windows. Pretty weird right?

Any ideas what to do about this?

2

This also happened to me. This is because of a code issue in Android itself, no matter what version you are running it up to until Marshmallow 6.0.1, not with Windows. The workaround is to move or copy the file/folder you want to see in Windows using a File Manager on Android.

  1. On Android, go to the File Manager.
  2. Move the File/Folder on a different location.
  3. On Windows, go to the location where you moved/copied the file/folder.
  4. Voila! The file/folder is now there.

EDIT: Go to your Apps and clear Media Storage cache then reboot. Worked on mine.

  • This answer works. The reason it works is related to the MTP protocol needing to be refreshed. File managers refresh MTP usually after each change they make to the filesystem. See this question for reference: stackoverflow.com/questions/13507789/… – Nitay Dec 13 '16 at 14:42
0
  1. Connect your phone to the computer.
  2. In the status bar, You will get USB symbol.
  3. Tap on that and change the settings from 'camera' to 'MTP'

This will help you to solve the problem. If the problem still exist, Copy your personal folder to DCIM folder. Now u can access that in Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.