Running Windows 7, and I have just downloaded the latest Android Studio version, and started a project. Now I'd like to test the application on my device but Android Studio says on the bottom left "No devices connected". I've tried a couple of things such as:

  1. Updating my Samsung S6 edge drivers through device manager, which were updated now.
  2. Have debugging mode turned on and USB debugging mode on.
  3. Ran adb devices command to list devices but none show up.
  4. Downloaded new universal ADB drivers.
  5. Toggled between MTP and PTP modes.
  6. Restarted computer/phone/Android Studio/ADB tens of times.
  7. Deleted phones drivers from device manager and installed again.
  8. Re-installed Android Studio.

I'm at a loss as of now. How do I fix this issue?

  • Please mention your android version and is your phone rooted? and Why don't you try using an emulator for development and testing purposes?
    – Lucky
    Aug 6, 2015 at 16:48

5 Answers 5


Windows 7 doesn't always detect the android device connected as an interface for adb. If your Samsung drivers is not detecting the phone you have a few choices:

  • Try reinstalling the Samsung android drivers. Might be a good idea to remove the universal android drivers but I don't have that problem with my Windows 7 machine.
  • You can mod the inf of the universal driver with your device's VID and PID by adding it if it's missing (which it possibly is missing since it's not a nexus/google device). Then use Device Manager and point your device to that driver to use and install.
  • Remove the Samsung android driver and the universal driver. Then install Samsung's Smart Switch app, which will install the latest Samsung android driver.

If you are committed to using the universal android driver, then you need to make sure you have the latest updates with the Android SDK Manager. If your tools are out of date or not the latest your tools may be out of sync with the platform it's trying to connect to.


Samsung always make things difficult. When I had my Note 4(Now Nexus 6) and was trying to do things via ADB. I did pretty much everything you did. It wasn't until I uninstalled the universal drivers and installed the Samsung ones that can be found here. I assume you downloaded the universal ones from Google as well. Those have never worked for any Samsung device I have owned. Hope this helps. =)

  • So I got the ADB to recognize the device but i'm having some other issues, I will download the drivers you just suggested now! @jer3my
    – ayounis90
    Aug 7, 2015 at 17:19

I just installed this tool https://forum.xda-developers.com/showthread.php?t=2588979 and it fixed my problem. I suspect it was because the tool installs the right driver. I downloaded it from the "Google" URL on that page

To add more info - it only fixed things for my Google tablet. Which identifies as Asus Nexus 7. So far this method didnt help me connect to my LG Android phone. Perhaps I should select a different drive from that web page.


Some things to consider:

  • Try installing "Kies", for some old phones I remember that was the solution, and maybe still is. 

  • Also try another computer, maybe a Mac, and see what it does there. The USB ports have more power.

  • Or try a high-power external USB hub, Anker, or similar.

  • What cable are you using? Crappy ones are often not working. Try a new short (!) USB 3.0 cable.

  • Does your PC have USB 3.0? Sometimes there are only a few ports upgraded (blue sockets).

  • Did the phone ask you to trust the PC? Can you delete all data about trusted PCs? Not sure what it is called.

  • Do you have another S6 that works?

  • Get a real Nexus device from Google for development, they usually work.

All the trouble we have in development is the knock-off stuff from Samsung with their own classes that miss functionality, and ignore parameters, ... Keep a Samsung device around to test if the app breaks, but don't spend too much time making it perfect. You're paying with your time because they saved a lot of money on development. I don't know how much time we spent on bugs just to end up on a post saying oh yeah, that's a bug in Samsung with 4.2.2, here's a workaround that will waste the rest of your day. When getting user reports, make sure to ask first if it is about a Samsung device, then decline to help ... or start googling for known bugs. :-) Seriously, they have a big market share, so make the stuff work, but for Android, it would be better if it moved towards a standard and manufacturers cared for it.

Reads maybe like a rant, but as a rule of thumb: When there is a problem and a Samsung is involved, the problem is never in your code.

  • Kies does works for older devices. Its more of a pain for the newer devices. Devs and users over on XDA often recommend uninstalling Kies and installing the USB drivers that can be found in my answer.
    – jer3my
    Aug 7, 2015 at 3:21
  • @marty Thanks for all the suggestions! I will post the answer i found out but all your suggestions are very useful. I do not have another s6 and i have a very good usb wire i'm using with usb3.0 on my laptop! basically I was missing the adb_usb.ini file from my .android folder.
    – ayounis90
    Aug 7, 2015 at 17:17
  • Yes, Kies is for older phones. Use Smart Switch for newer phones. Aug 7, 2016 at 3:31

On my Nexus, the USB mode has to be in Camera in order for ADB to work. I am not sure why. In that mode, I cannot copy files, but the ADB connection works just fine.

  • 5
    The OP has mentioned that he has tried both the MTP and PTP modes.
    – Lucky
    Aug 6, 2015 at 16:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .