0

Is there any way to access or log the process list when the phone is off, but plugged into my computer charging? I'd like to see what system processes are running when the phone is connected to a power source but is not yet turned on.

My device is rooted, but more importantly my bootloader is unlocked.

5
  • 2
    If someone ever makes a device that can run appse when you haven't yet powered it on I'd be impressed.
    – Chenmunka
    Commented Aug 7, 2015 at 14:53
  • @Chenmunka, see answer below Commented Aug 7, 2015 at 15:05
  • @Huey it's not in recovery mode. Reproduce steps are literally, 1. turn phone off, 2. plug phone into computer. If you look at the display, it's just showing the charging animation because the phone is off and plugged into a power source. Commented Aug 7, 2015 at 15:58
  • @Huey, you might've misinterpreted the question, I was looking for the process list, not a list of all running apps. So I could see what system processes were running when the phone is plugged and only charging - linuxcommand.org/man_pages/ps1.html Commented Aug 7, 2015 at 16:20
  • @Huey included a picture of the output to help alleviate any confusion Commented Aug 7, 2015 at 16:22

1 Answer 1

0

Just figured it out, pretty easy actually. If the bootloader is unlocked and the device is powered off and plugged into your computer, you can just use ADB.

Typing >adb devices will result inadb devices output for device charging

You can then run adb shell "ps" and it'll output the process list while in charge mode, like seen below:

enter image description here

12
  • 2
    Where did you get that info from? That recovery under "List of devices attached" shows up when you're booted into Recovery mode, which means the device is powered-on. This answer is bizarre, though may be true that a very small kernel is running to show that power animation or something! I demand further clarification. And which device are you using? The method doesn't work here on unlocked OnePlus One.
    – Firelord
    Commented Aug 7, 2015 at 22:48
  • @Firelord understandable, I also don't know.. Info is completely empirical. I didn't expect it to work so I asked the question, then tried a few things out. Perhaps, since the device is off, ADB is assuming it must be in recovery mode because it wouldn't expect an unlocked bootloader. Would have to open the adb code to see what's going on exactly. However I am positive I was not in recovery mode. I literally turned the device off, plugged it in, and used ABD. I would be completely willing to record it as video for the sake of us all. Commented Aug 7, 2015 at 22:49
  • 1
    @Firelord didn't see your edits before I commented. The bootloader is a kernel that takes care of booting the system, and is what runs when the device is charging but off. I was using a Huawei Y536A1. According to XDA was also possible on LG Ultimate 2 (all that I know, I don't have any more devices to test with). Commented Aug 7, 2015 at 22:53
  • 1
    If you really didn't miss something here, that's pretty weird. In order for your local ADB client to see the device, the ADB daemon on the device must be active – which requires "something" to be booted. The absolute minimal system active while charging the switched-off device is very unlikely to do that (at least I've never seen such). So could you please answer @Firelord's question and let us know what device this is, and also include what ROM/Android version you use there?
    – Izzy
    Commented Aug 7, 2015 at 23:10
  • 2
    @Izzy absolutely. I did mention this was on the Huawei Y536A1, however android version is 4.4.3. As for rooted ROM, I took it from an XDA post, I will comment the link at a later point tonight when I'm not on the mobile app. In this post forum.xda-developers.com/optimus-g-pro/d680-development/… a user found a bug in the bootloader that allowed him to access it via ADB with a locked bootloader. LG device bootloaders since have had a security upgrade, but it led me to try it on the unlocked Huawei where it also worked. Commented Aug 7, 2015 at 23:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .