1

I've got an issue setting up the AVD in my Android Studio as Intel HAXM is not working with my Windows 10. So, I am trying to debug and run my projects with my Android device. However, after trying to download the Google USB driver and replacing it with the standard driver that comes with Windows, I find I am not able to:

The issue I am facing

By the way, I am trying to replace this driver with the Google driver or the driver offered by Samsung - both turned up with this error.

But when I check the Android Device Monitor, my phone is not listed as it did in the tutorial I watched. (My device is a Samsung W GT-I8150 - Android 2.3.5 Gingerbread)

Any help or advice will be most appreciated.

Raihaan

  • What is the reason you are trying to install this driver? – Lucky Aug 9 '15 at 9:49
  • I want to debug my projects on my device as my Virtual Device requires Intel HAXM, which doesn't want to work. Right now I am exporting all my projects into signed apks and installing them on my phone one at a time - not very efficient. – Raihaan Aug 9 '15 at 15:43
  • Have you turned on the USB-debugging in the Developer settings under the Settings menu and your usb mode is PTP? See if this post helps. And can you see the device listed under adb devices command. Run adb devices command in the command prompt under the android-sdk folder which will be usally found under ~ANDROID_SDK/platform-tools – Lucky Aug 9 '15 at 17:24
1

In Win10 use this:

  1. Uninstall previous Samsung USB drivers from “Programs And Features” and “Device Manager”.
  2. Power off your Samsung phone. Switch your Samsung phone into download mode (power it on with Power + Vol UP + Home pressed simultanously).
  3. Connect it to your computer via USB cable. Your phone should become discovered by Windows as some device. In my case, Windows has found my phone as a “SAMSUNG Android ADB Interface” device.
  4. Restart your phone.

Now it all. Phone driver work perfectly.

0

According to the last post on this forum, Samsung simply doesn't have a windows 10 driver.
I am stunned that Samsung did not anticipate the Windows 10 release.

-1

All I did was go to the Applications->USB Settings and cleared cache. It stopped working on the last W10 update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.