4

I installed Android Studio, but when I try to run, the emulator is not working. When I googled, I find some instructions in which the

  1. Open SDK Manager and Download Intel x86 Emulator Accelerator (HAXM installer) if you haven't.
  2. Now go to your SDK directory (C:\users\username\AppData\Local\Android\sdk, generally). In this directory Go to extra > intel > Hardware_Accelerated_Execution_Manager and run the file named "intelhaxm-android.exe".

    In case you get an error like "Intel virtualization technology (vt,vt-x) is not enabled". Go to your BIOS settings and enable Hardware Virtualization.

  3. Restart Android Studio and then try to start the AVD again.

but I don't know where is BIOS setting of my computer. I have HP desktop CPU and try to find the BIOS from start, F10 as well as from change PC setting in Windows, but all in vain.

2
  • 1
    PC/Mac/Linux-based questions are off-topic here at Android Enthusiasts, as this is an end-user site for Android, as long as it does not have any direct implication on an Android device. Please consider asking your question on SuperUser. Dec 1, 2015 at 9:09
  • I'm voting to close this question as off-topic because it's more related to general computing (PC BIOS) and not about Android.
    – Andrew T.
    Dec 12, 2021 at 2:46

3 Answers 3

2

I faced a similar problem recently on my windows 10 laptop and found out that the Intel virtualization technology (vt-x) was disabled from BIOS.

In case you are using a new laptop which comes per-installed with Windows 8/8.1/10 then chances are that you cannot enter the BIOS manually while booting. Reason being they have changed BIOS to UEFI which is no longer accessible through boot but instead you need to do the following steps:

Go to Windows > Settings > Update and Security > Recovery. Then under Advanced startup, click Restart now. The system will restart and show the Windows 10 boot menu. Select Troubleshoot > Advanced options > UEFI Firmware Settings. Click Restart to restart the system and enter UEFI (BIOS). from here you can access the UEFI menu (which is similar to BIOS)

Search for the VT-x setting (It may be named as Intel VT or Vanderpool or Virtualization Extensions or something similar depending on your OEM and BIOS.)

Please refer to this link for screenshots on how to access the UEFI from windows 10: http://www.howtogeek.com/213795/how-to-enable-intel-vt-x-in-your-computers-bios-or-uefi-firmware/

1

If your new Mac M1 is having this problem, as of Android Studio Arctic Fox patch 4, I resolved the issue by adding a new virtual device (for the simulator) which was for ARM architecture. Here are details with screenshots about the steps on ConfessionsOfAnAgileCoach.

0

When you switch on your device, it starts to boot as your preferences (HDD, Removable drive, Optical drive etc.) set in the BIOS. Before the OS boot starts, if you press a particular key,your device will show a window with options like Boot menu, BIOS settings etc. You can find the buttons beside each option, by pressing which you can enter those options. For example,

Acer - F2

Asus - Del

DELL - F2

HP - F10

These keys may be changed.

After you enter the BIOS set up goto the Advanced tab and enable the Intel virtualization technology, which may be aliased/called as Intel VT-x or AMD-V.

Hope this will help.

1
  • for Lenovo pc u can use Fn + F2 key to go into bios setting.After changing bios setting i am sure your AVD will work Mar 4, 2020 at 4:13

Not the answer you're looking for? Browse other questions tagged .