21

Problem: Install ADB drivers (google_usb_drivers) on a Windows 10 client in order to enable debugging for my OnePlus One (OPO).

What I have tried: After some Googling I found several guides telling me to add the devices hardware id to googles driver "android_winusb.inf" under [Google.NTx86] and [Google.NTamd64].

;OnePlus One
%SingleAdbInterface%        = USB_Install, USB\VID_05C6&PID_6765
%CompositeAdbInterface%     = USB_Install, USB\VID_05C6&PID_6765&MI_01 

After manually selecting this file as the driver using Device Manager, I get this error message: The hash for the file is not present in the specified catalog(...)

Device Manager Error

Googling this error, I found many references to similar problems with Windows 8.1. They all suggested to (scarily I might add) turn off signature checks on drivers using the command:

bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS

This however, seems to have no effect - I get the same error as before. Have this feature been disabled or changed since Windows 8.1 maybe?

Question: Does anyone know how to get ADB up and running on a Windows 10 machine? If so which steps did you take? Am I completely off with what I've tried so far?

  • Hi efr4k! This site is not a forum but a Q&A site, so even if you've an answer for your own question, you should follow the format of the site. For now, I rolled back to the first revision because it is the only revision devoid of your answer. Please post your answer as an answer in the answer's section. For readers: here is the answer at the end of the current question. – Firelord Oct 19 '15 at 0:17
12

Try the 15-seconds ADB/drivers all-in-one installer. You could also install the Samsung drivers rather than conventional OnePlus drivers.

I installed these drivers and I've had mine working since the upgrade.

You could also try following this guide on how to set it up.

  • The guide pointed me to the right clue. Don't know if installing the driveres using the 15 second installer was necessary, but I'm not gonna start over with a clean slate to check. I updated the question with the clues from the guide that was relevant for solving the problem. – efr4k Aug 19 '15 at 20:51
  • just a good idea to see if the upgrade to windows 10 broke something. It did for me and I assumed it may do for others... – iTechy Aug 20 '15 at 9:37
  • I installed it directly on two W10 machines and it worked on both. – Pupper Oct 19 '16 at 23:12
  • Both 1.4 and 1.3 versions not worked on my Win10. – HQtunes.epizy Dec 13 '16 at 22:12
0

Google's adb driver works fine with any Android phone. It's Microsoft policy to forbid class drivers so each vendor is required to provide same driver with different hardware ID and to pay money for Windows Logo® program and signing process.

As it is in Linux ))

To temporary disable integrity/signing enforcement, run as Administrator:

bcdedit /set testsigning off

reboot, install driver and then:

bcdedit /set testsigning on

and make final reboot (can be done later).

You can follow my blog post on subject Connect to Android via USB by adb in Windows

3

I couldn't update the ADB driver on Windows 10. When I tried installing the generic Google ADB driver by clicking on "Browse my computer for driver software" and choosing the driver folder, Windows ignored the drivers, saying there were no drivers found.

I finally found the solution in this article, Manually installing Android ADB USB Driver.

The missing step is to continue guiding Windows after clicking on "Browse my computer for driver software". When selecting the folder with the driver, click on the "Let me pick from a list of device drivers on my computer". Select "Show all devices", then "Have Disk". This defaults to drive A: --- navigate to the folder with the extracted USB drivers, probably named usb_driver. You'll then be able to choose "Android ADB Interface" and install the driver.

This allowed me to connect OnePlus One to Windows 10 for debugging. I could navigate in Chrome to chrome://inspect/#devices and see my device.

  • 1
    this works to get windows 10 to actually install the drivers instead of giving up early. hasn't quite fixed my connection issue with ADB, but it's a start. – worc Nov 6 '17 at 22:07
1

I had similar problems, adb devices didn't list any devices once I'd upgraded to Windows 10. I happened to have an Intel-powered Android phone connected over USB. I ended up removing the Intel-specific Android Driver (downloaded yesterday, version 1.9 which doesn't explicitly support Windows 10) and then used the universal Android USB driver https://github.com/koush/UniversalAdbDriver following the steps described in the following article (using Device Manager and removing the previous driver). For good measure I disconnected and reconnected the USB cable after removing the previous driver and before selecting the replacement driver.

http://www.makeuseof.com/tag/android-wont-connect-windows-adb-fix-it-three-steps/

My computer has several possible matches in Device Manager when I selected choose the driver manually. I checked each one until I found what seemed to be the relevant one i.e. the Universal Driver, then from the list I picked the Android USB Driver. As you have a different device, you may need to pick a different device driver from the list.

protected by Community Oct 29 '15 at 13:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.