1

My phone is Xperia SP, it's on CM 12.1, unofficial build (because the official one is buggy due to bad kernel). It has been bought second-hand, so I'm not sure about its history (the phone was in a good state).

So, the problems started gradually, but the symptom is this: when I connect the phone to the charger, the phone goes into it's charging state, the battery icon shows the charging symbol, the LED shines red, but the phone doesn't actually charge, and the battery percent actually actually descends. I would usually just detach the phone, and reconnect it, and it would actually start charging. However, this happened more often as the time passed, to the point where it is completely empty, and it cannot be turned turned on, or charged. When I connect it, the LED goes red (the usual charging behaviour), but then it goes into booting the system, instead of going into "offline charging" mode. It fails to boot the system, because the battery is empty. It then turns off, returns to the red LED state, and from time to time it boots into recovery, which is quite unusual, since by default one has to press volume buttons to enter recovery. While in recovery, usually it would display the battery percentage, but now the place which should show the battery percent is empty.

Are these the symptoms of an faulty battery, or a more severe issue? Did anyone experience anything similar?

2
+50

I had a similar problem a few years ago with my old HTC EVO 3D which was also running cyanogenmod at this time. I tried flashing different roms and kernels but the problem was persistent. Because my battery was empty as yours is at the moment, I charged it by cutting a USB Cable and applying "+" and "-" to the battery directly. It looked really bad to be honest but it worked and I was able to go back to stock. But that didn't help. The point is - I could make sure that the battery is not defective because I was able to charge it. In the end the problem was the usb port of my phone which had to be replaced. It worked but to make sure my phone does not turn into a torch I also replaced the battery.

What you describe could be the usb charging port - there might be a faulty contact which prevents the battery from charging but this is just guessing. Bottomline: Try to charge your phone by a usb cable (please be very careful while doing this) or visit a service center.

  • Did your phone react to being plugged in? My recognizes it in an instant, and doesn't disconnect when I move it around, so I wasn't quite convinced that the port is the issue... – Aleksandar Stefanović Aug 13 '15 at 16:20
  • Yes it was working fine most of the time, like I mentioned: I was able to copy rom zip files from my computer to the phone - there were occasional problems but at that time I didn't think that the USB port was the error cause. The charging LED was also working but I wasn't able to charge the battery in the end – benjamin Aug 13 '15 at 16:23
  • Just an update, (I know it's late but I want to help people that have the same issue). It was indeed the USB port, I got it replaced for about €10, and now it's working fine. – Aleksandar Stefanović Nov 27 '15 at 22:04
  • @AleksandarStefanović Good to hear - thanks for the update! – benjamin Nov 30 '15 at 7:04
1

Battery Check

  1. Visual Inspection
    If the battery of your phone is removable, simply take it out with caution (after turning the phone off, of course) and look for symptoms like bulging, corrosion near the metal terminals, and green or white-ish stains
  2. Spin test
    Your battery shouldn't spin like this
    enter image description here
  3. Battery diagnostics
    Try entering the code *#*#4636#*#* in your dialer –this should take you to a service menu where battery details are shown

Charger

  1. Right Charger
    Charge your phone with Sony provided charger

If anything is not fine, it is time for battery replacement

1

I had the same problem I.e. It physically looked like it was charging but the percentage was going down

The solution was to remove the back cover and press the little off button with a pen hold it down until it vibrates and all should be cool and groovy...

Hope this helps you....

Primeval

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.