Cannot make this work...Windows 7, have installed DE and Android SDK... I can go to this path using regedit HKEY_LOCAL_MACHINE\SOFTWARE\DroidExplorer\InstallPath

BUT I see no "sdkpath". I've tried pointing the DE to the Android SDK directory in hopes of finding SDK anything...NOTHING. What am I missing ?

  • are you on a 64bit machine? if so take a look at HLKM\SOFTWARE\Wow6432Node\DroidExplorer\InstallPath\. On 64bit, this node still resides in the 32bit hive. Aug 11, 2015 at 21:46
  • @RyanConrad that registry key points to C:\Program Files\Droid Explorer - it doesn't point to SDK. He's asking about the sdk path. I'm having the same problem. I've installed the SDK, but when I try to install DroidExplorer, the installer gets hung up at the Specify Path to the Android SDK window - which is horrible because it only lets you browse there; you can't just paste the path - but it won't accept any path you put in the box and so you are forced to push the cancel button.
    – bgmCoder
    Apr 15, 2016 at 18:48
  • If you have a 64-bit machine check in HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\DroidExplorer\InstallPath@SdkPath - I know, a registry cluster... I have it on my backlog to clean it up. Apr 15, 2016 at 23:22

2 Answers 2


After you install the Android SDK, you have to run the studio.exe or studio64.exe before you install DroidExplorer. This might install a bunch of platform updates.

Check this post of Ryan's for a full explanation of what to do.


Right. I saw the other page where Ryan explained the procedure in detail. What some of us forget, even people like me who have installed SDK at various times in the past, but don't use it much, is that after downloading SDK, or Android Studio as it is called now, you have to actually run SDK Manager or Android Studio before the tools will actually be downloaded and the paths created for Droid Explorer to use.

I should know because I've gone through this before, but having been years since the last install, I had forgotten this detail, which is not really explained anywhere. I notice Ryan's tutorial on this site did show screenshots of SDK Manager, and said you have to actually run it and install some tools, and that's what triggered my memory.

It doesn't help that documentation talks about SDK and SDK Manager when these products are no longer available for download, and the Android Studio download site hides the SDK tools only download at the bottom of the page, and then incorrectly states that SDK Manager is included, which it no longer is.

So I lost a lot of time looking all over the internet for an old Android SDK download before I realized what Ryan was talking about. After actually running Android Studio and letting it download and install the components, Droid Explorer successfully ran and finished installation. It still doesn't automatically detect the path. I had to manually browse to the SDK folder. Note you have to select the SDK folder itself. Selecting Android alone is not sufficient.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .