1

I cannot install applications from the Google Play Store. When I try, it says "Error while retrieving information from server."

My phone is a Samsung Galaxy S4, running Android 4.3. How can I fix this problem?

  • samsung galaxy s4 android 4.3 jellybean. – Shane Halasan Aug 11 '15 at 15:47
  • Please help. Can't use my phone, some apps need to be updated. – Shane Halasan Aug 11 '15 at 16:06
0

These steps should fix this.

  1. Go to settings> apps >play store. Then tap clear data and cache
  2. Go to settings>accounts>Google then remove account
  3. Reboot your phone
  4. Log in with your Google account and open play store. Done.
  • Tried for how many times, still didn't work. :-( – Shane Halasan Aug 11 '15 at 23:26
  • I couldn't even update google play services. "Google play services could not download due to an error.Error while retrieving information from server." – Shane Halasan Aug 11 '15 at 23:32
0

if your phone is rooted you can try to edit host file in etc folder of device and add # to every line that doesn't contain # except the first line that is 127.0.0.1

  • Do you know # will make the line a comment. That means you want to deactivate some codes – Thally Ace Dec 7 '17 at 5:32
0

Settings> Applications > All> Downloads > delete data. Settings> Applications > All> Play Store> delete data. Settings> Apps > All> Google Services Framework (or if they have it in English: Google Service Framework) > delete data.


if the above method doesn't help, try this:

Method 1: Clearing the Cache.

This is a cliché, But hey it works half of the times. In this method all you need to do is Clear the Cache and Data of few Google Apps. Go to Settings. Tap on Apps. Select Google Play Store Tap on Clear Cache and Clear Data. Do the same for Google Play Services too. Once done, Try and download the app that was showing you error retrieving information from the server with code DF-DLA-15.

Method 2: Clearing Dalvik Cache

On Research, we learned that Clearing the Dalvik Cache have helped few users to overcome DF-DLA-15 Error. What is Dalvik? You may ask. Well, Dalvik is a JAVA Based Virtual machine which is the base of all the Programs. This Method Requires you to have Root access and Root Explorer app. To name one of them is "Ex File Explorer". Now let us see how to clear Dalvik Cache. Using Ex File Explorer, Open Root Directory. Now Navigate to /data/Dalvik cache. Select & Delete all the files from Dalvik cache folder. Reboot your Android Phone. That is it, now try and download the app again. If Dalvik cache was responsible for the error DF-DLA-15 then, the error must now be gone.

Method 3: Uninstall Updates.

NO, I am not talking about your phone updates. Here i am talking about Google Play store updates. Recently updated Play store might have compatibility issues with apps and hence popping Error messages to you.

Simply Goto Settings > Apps > Google Play Store > Uninstall Updates. Once done, Reboot your Phone and remember don't update play store just yet. First try do download the same app that was throwing Error DF-DLA-15 on your Screen.

Other Methods:

1: Adding Credit Card details to Play store have resolved the problem. Try It yourself and let us know in comments if the same works for you too.

2: Unmounting SD card have worked for them. So Un-mount SD Card(Steps Below) or Completely Remove your SD card and try again.

Let me know your results or if you have questions.

0

Name Of The Error: Error retrieving information from server Problem: when Google's servers are unable to retrieve information from your Google account during the updation or downloading process, you can sometime get encounter with this error. Solution: • First of all Go to the Settings> Then Accounts> And then Google 'to delete your Google Account'. • Once this is done, you must reboot your device, then re-synchronize the account. • Finally, open the Settings. • Click on “Apps or Application manager”. • Then swipe to the All columns. • Scroll down the cursor until you see “Google Services Framework”. • Finally choose “Clear Data” and force Stop.

If you want to get updated against more play store errors you can visit:

0

One thing to take care of: Ensure the app at:

/system/priv-app/DownloadProvider/DownloadProvider.apk

is intact or else everything you try will seamlessly fail

-1

I was getting the same error, when I tried downloading an app with wifi. I switched from Wifi to data pack and that error went away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.