Whenever I run adb backup for a full backup, it never finishes. In Terminal, the command hangs indefinitely, and on the device, the backup cycles through a few apps before hanging on one (more about that at the end of this question).

After executing adb backup, the backup file on the PC slowly increases in size, but after a while it stops growing. I've let it sit at this point for an hour without any change in the size of the file.

I've tried running adb backup 3 different ways ($ab is just the name of the backup file):

adb backup -f "${ab}" -apk -obb -noshared -all -system
adb backup -f "${ab}" -apk -obb -shared -all -system
adb backup -f "${ab}" -noapk -noobb -noshared -all

Not even the last one works. I also tried setting up a desktop backup password under here:

Settings > Developer Options > Desktop backup password

This didn't help either.

This problem occurs with two different devices, both rooted. Both devices run on Android 5.1.1, so maybe it's a bug with this version of Android? It didn't work on 5.1 either. One of the devices is a Nexus 6 using the official Android 5.1.1 image, so it's not a bug with a custom ROM.

The last few times I tried running adb backup on the Nexus 6, I noticed that it started hanging on the same app each time: Titanium Backup. I don't know if this has always been the case; I just noticed it recently.

Does anyone have any suggestions? Also, do any other Linux users have this problem too? If so, it's likely a bug within the adb package.


After running adb backup again, it worked! I'm guessing it's because I upgraded my Nexus device's firmware to a slightly newer version: from LMY47Z to LMY48I (both are Android 5.1.1). Maybe it was a bug with the earlier 5.1.1 build, the one before the "Stagefright" fix was added.

  • 1
    Is there a reason you don't want to consider a Nandroid backup or apps backup using Titanium Backup?
    – Firelord
    Aug 12, 2015 at 3:59
  • 1
    Green i am running 5.1.1 om ny samsung tab and tried your method. I can't even get into the device. I get the now unlock your device message and then the process dies/exits. Trying the same in recovery is the same. I am running kali. It's a toss-up between the distro's adb source/implementation and i am guessing selinux, maybe?
    – moonbutt74
    Aug 13, 2015 at 12:08
  • 1
    @moonbutt74 I'm using Arch. One of my devices is a Samsung tablet too, the Galaxy Note 10.1 2014 edition. I just had an idea--maybe running it as root would help. (Nice name btw lol) Aug 27, 2015 at 13:10
  • 1
    GreenRaccoon23, hi , sorry i should have mentioned the root aspect, i was rooted and running as root. I would say it's likely specific to Samsung devices but I don't have a device from another manufacturer to put that against.
    – moonbutt74
    Aug 27, 2015 at 13:15
  • 1
    One of mine is a Motorola Nexus 6, so it doesn't look like just a Samsung problem. Aug 27, 2015 at 13:17

1 Answer 1


SettingsAppsTitanium BackupForce Stop may allow the ADB backup to continue and finish.

  • Why was this downvoted?
    – Reinderien
    Oct 4, 2017 at 18:50
  • 1
    I had by backup hang on a different app, and killing it in this manner worked for me to allow the backup to continue.
    – rkjnsn
    Jan 25, 2018 at 8:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .