0

I have a HTC G2 running Android 2.3.4 that I've recently tried to root using the guide at the XDA developer's site. After step 3.3, the USB connection stopped working. More precisely, when I plug the USB cable into the PC and the phone, the PC does not detect the phone (for instance, it is not in the devices manager) and the phone does not get a USB notification (though it does charge). I've tried all the basic trouble shooting steps as outlined here, but I haven't had any luck fixing the problem.

As I see it, either one of two things has happened. The phone's USB port needs to be replaced or I've introduced a glitch that prevents the phone from communicating with the computer. Is there a way to find out which case I'm facing and if it's the second case, how to diagnose and fix the glitch? Thanks

  • I assume since you had it working at one point, You have Dev options enabled. Try revoking USB authorizations and then plug in the device and see if it prompts you to allow the connection. Assuming your android version has it. and if not, what android version are you running? – jer3my Aug 13 '15 at 3:57
  • It is version 2.3.4, which does not (as far as I know) have USB authorizations. I did try turning off USB debugging, but that didn't help. – graf_ignotiev Aug 13 '15 at 14:17
-2

I understand your problem,Your device may not have supported Drive and check is it connect mass storage(memory card) or not .if you may change the setting in USB debugging,

  • You didn't answer the question... – Bebs Jan 19 '17 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.