5

as I am really desperate now about the wlan problem on my Samsung Galaxy S3 GT-I9300 I am now going to post a question in the hope that someone might help me fix it.

Problem description:

I cannot activate wifi. Logcat shows me that the driver could not be loaded (detailed wifi logging has been activated via the developer options):

D/WifiService( 2240): setWifiEnabled: true pid=3142, uid=1000
E/WifiService( 2240): Invoking mWifiStateMachine.setWifiEnabled
E/WifiStateMachine( 2240): InitialState !CMD_START_SUPPLICANT 0 0
E/WifiStateMachine( 2240): Failed to load driver

The netcfg command does not list any wlan0 interface! lo UP 127.0.0.1/8 0x00000049 00:00:00:00:00:00 sit0 DOWN 0.0.0.0/0 0x00000080 00:00:00:00:00:00 ip6tnl0 DOWN 0.0.0/0 0x00000080 00:00:00:00:00:00 rmnet0 DOWN 0.0.0/0 0x00001090 00:00:00:00:00:00 rmnet1 DOWN 0.0.0/0 0x00001090 00:00:00:00:00:00 rmnet2 DOWN 0.0.0/0 0x00001090 00:00:00:00:00:00

In the wlan advanced settings there is no mac address available.

The wifi status that can be reached via the #*#4636##* service code on the phone numberpad lists the following information:

Wi-Fi state: Disabled
Network state:
Supplicant state: UNINITIALIZED
RSSI: -127
BSSID:
SSID:
Hidden SSID: false
IPaddr: 0.0.0.0
MAC addr:
Network ID: -1
Link speed: -1 Mbps
Scan results:

Android version:

The phone is rooted, ClockworkMod Recovery (CWM) is installed.
I tried different custom roms (see next point "history"). The current Android version is 5.0.2 (ROM: Liquid Smooth Lollipop, Kernel-Version: 3.0.31-CM-gdd7ad6a)

History

At first I rooted my phone and flashed Cyanogenmod 10.2 cm-10.2.0-i9300 (Stable Version, Android 4.3)). Everything worked fine (including wifi) and I was pleased with the smoothness and beauty of the Cyanogenmod.
Out of curiosity I tried a Cyanogenmod cm-11-20150614-NIGHTLY-i9300 (Android 4.4) and faced the problem the first time. After returning from airplane mode, the wifi was broken. I assumed the nightly build to be still buggy and reflashed the Cyanogenmod 10.2. However, I was not able to get the wifi back.

After that I returned to a stock rom but no luck! Wifi was still dead :-(

I started to consider that it might be a hardware issue and got a new wlan antenna as well as a new wlan-speaker-thingy. I changed the parts and tried again with Cyanogenmod 10.2. Guess what! Wifi was working again! But unfortunately not very long. I am not quite sure but I assume the wifi went away again after returning from airplane mode.

Well, I then cried silently in a dark corner of my room...and tried two other custom roms: SlimKat 4.4. Slim-i9300-4.4.4.build.9.0-OFFICIAL-8312 and Liquid Smooth Lollipop (5.0.2) which is still on the phone.

On Liquid Smooth I was able to get the wifi back for a couple of times (meaning I could see local networks in range and even connect to one of them) but never really long and in the end it died again forever.

I am really confused about the question: Is it a software or a hardware issue? I sent the wlan-speaker-module back to the merchant and tried another one but was not able to revive the wlan since then.

It's so sad. Everything else is working so nice and properly on the phone and it's still looking as if it is new. I know that its monetary value is quite low now but I have invested so much time into it (and also bought the new hardware) so I really hope that there is still a chance for fixing.

Other things I tried

I tried some wlan fixer apps (without success):

  • Wifi Fixer
  • Blade Wifi Fix
  • FXR WiFi fix and rescue 1.5.0

I tried some useless stuff with the wpa_supplicant.conf file that I have read about in another forum.

In addition to that I was almost googling myself to death...I think I got through the whole first page of search results for a lot of search terms.

Logcats

I pasted the detailed logcats in pastebin:

  • Liquid Smooth boot on the day wlan was working for a short period of time: http://pastebin.com/dT9Ucbs5
  • Liquid Smooth successful wlan activating (search for "banana" that is the SSID I connected with): http://pastebin.com/yQsgkQiV
  • Liquid Smooth boot and failed wlan activation (freshest log): pastebin.com/ikDr9vJi (I can post only 2 links...)

I would really appreciate any kind of help or advice. What can I still try? What could be the cause of the problem? Anything I have overlooked?

EDIT: I also uploaded the dmesg output: http://pastebin.com/0caXAPAd

There is a message

failed to power up DHD generic adapter

  • +1 for doing your due diligence! It's not a hardware challenge I think, it's rare for a flash to murder a single part in your phone. Could it be a kernel challenge? Do you know if it was modified during your CM11.2 flash? – ZeroPaladn Aug 13 '15 at 12:30
  • Ramona, hi, please post the output of mount | grep efs Also link me to the rom you flashed when this started? – moonbutt74 Aug 13 '15 at 12:31
  • 1
    @ZeroPaladn Unfortunately, I don't know if the kernel was modified during the flash. @moonbutt74 Output of mount | grep efs is /dev/block/mmcblk0p3 /efs ext4 rw,nosuid,nodev,noatime,user_xattr,acl,barrier=1,journal_async_commit,data=ordered 0 0. I got CM 10.2 from here, CM 11 from here. Thx to both of you for your comments. – Ramona Zeppelin-Punkt Aug 13 '15 at 12:57
  • Ramona, okay i'm getting both now, iwant to compare the boot.img's , quick question, if you can , backup current rom and do a clean flash of cm-10.2.0-i9300, meaning factory reset and/or clean to install new rom. – moonbutt74 Aug 13 '15 at 13:04
  • I dug up a forum post that goes through a similar challenge, it also mentions a botched kernel. You could try replicating the steps from post #8 and #12 (read them both first). – ZeroPaladn Aug 13 '15 at 13:11
0

okay i have to post this as an answer as there isn't enough room in a comment slot to cover this. After looking at your dmesg, if i am understanding it right, you wifi device is identifying as mmc2 and/ an external card

<6>[   18.525295] c1 mmc2: card inserted.
<4>[   18.525962] c1 wifi_platform_set_power = 1
<4>[   18.525970] c1 ------------------------------------------------------------------------------------------------
<4>[   18.525978] c1 brcm_wlan_power Enter: power on
<6>[   18.525983] c1 111brcm_wlan_power Enter: power on
<4>[   18.525988] c1 gpio_table = [2]

<7>[   18.526198] c1 WLAN: GPIO_WLAN_EN = 1
<4>[   18.730036] c1 wifi_platform_bus_enumerate device present 1
<4>[   18.730044] c1 gpio_table = [6] 

And is cycling on and off because it is having the wrong/excessive voltage being pumped into it.

<6>[   16.407671] c1 mmc2: card inserted.
<3>[   16.635241] c0 mmc2: cmd 52 command index error error
<3>[   16.636109] c0 mmc2: cmd 52 command index error error
<3>[   16.641166] c0 mmc2: cmd 8 command crc error
<3>[   16.641729] c0 mmc2: cmd 5 command end bit error
<3>[   16.642015] c0 mmc2: cmd 5 command end bit error
<4>[   16.642068] c0 mmc2: host doesn't support card's voltages
<3>[   16.642080] c0 mmc2: error -22 whilst initialising SDIO card
<3>[   16.643112] c0 mmc2: cmd 55 command end bit error

With new hardware you require a new kernel build with correct device support compiled into the kernel. Whether or not this "cycling" is damaging your new hardware i can't be sure. It wasn't really clear in your question but i am assuming these were internal changes to your phone's hardware? You will likely need to get the specifics of that new hardware and find the driver/kernel source/support and port it into your current source and compile a new build, modules and all.

Basically, any rom you flash on this "new" device is likely going to fail in the wifi department and flashing even back to stock via the/an official firmware release is not likely to fix it.

  • Yes, OP's hardware has changed - they replaced the WiFi "antenna and speaker-thingy" after the stock ROM flash didn't remedy the challenge. If the hardware isn't exactly the same as the original then yes, a kernel recompile with the proper driver would be required. – ZeroPaladn Aug 13 '15 at 13:57
  • thx for the insights! Fortunately, I did not throw away the original hardware. I now put it back into the phone and flashed the Android Revolution HD 53.0 ROM which is based on stock kernel. The flash should be clean, I did wipe data (factory reset), wipe cache and wipe dalvik cache. At least I now do not see any wifi related messages in the dmesg anymore and I got my mac address back. However, logcat now tells me Wi-Fi driver is unstable. Haha, this is really driving me crazy.... – Ramona Zeppelin-Punkt Aug 14 '15 at 11:26
-1

renaming of the data\misc\wifi\wap_supplication.conf file has fix the problem for some people

Edit: the android system by default will recreate the wap_supplication.conf file after renaming or removing , in my case either ways did worked but for short amount of time , finally i just relapsed the wireless adapter , so it's likely a hardware problem

  • Rename data/misc/wifi/wpa_supplicant.conf to what? I have seen solutions to remove this completely but not rename it. – Michael Gambrell Dec 7 '17 at 20:53
  • the android system by default will recreate the file after renaming or removing , in my case either ways did worked but for short amount of time , finally i just relapsed the wireless adapter , so it's likely a hardware problem – prog Hardud May 3 '18 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.