4

I'm trying to figure out whether or not I managed to brick my android phone, a Galaxy Nexus*.

Using ClockworkMod Recovery, I pretty much erased everything I could find (/data, /cache, /factory, /system, /boot, /sbl, /xloader). If I reboot now, will I still be able to boot into ClockworkMod? Specifically, /recovery is not on said list.

I am trying to find information on how the boot process works, but it is very hard to discover around the web among all the end-user specific noise. As far as I understand it, there is a stage-one bootloader in an actual ROM (emphasis on read-only), but I do not know whether the fastboot-functionality is contained in it.

Hypothetically speaking, if I were (able) to zero every block of the internal SD-card sans the read-only ROM, would that brick the device?

To my knowledge, as long as I can still get into fastboot, the device is not bricked? If all this fails, can I use special hardware to restore it?

*: I should note it is currently powered on and has loaded the ClockworkMod Recovery. I believe I could get it back to working order, but I really want to find the minimum amount of software I can get away with.

  • ....... Why? Alright, you said why, but still..... I have never heard of intentional bricking. If you can't restore it, what are you going to do? – Dan Brown Aug 13 '15 at 11:07
  • 1
    As it says in the text, I'm not intentionally bricking it; I just erased a bunch of things and am now wondering whether or not that did actually brick it. -- The whole "can I brick it?" question is just me trying to figure out things from the other end. – stacked_deck Aug 13 '15 at 11:10
  • Ok, but (assuming you do brick it) this is an intentional brick. Have you tried rebooting it? – Dan Brown Aug 13 '15 at 11:12
  • 2
    @DanB I have not rebooted it yet, since I am still inside the RecoveryMod, where it should be fairly easy to fix things. If it does turn out to be a brick, rebooting would close my door back in, so to speak. – stacked_deck Aug 13 '15 at 11:26
  • Fair point, but it would be the only way to check :( I just looked at my recovery, and found I had stopped the wipe of anything :) – Dan Brown Aug 13 '15 at 11:27
3

As far as I know, your device is not that hard bricked, that you can't boot into the bootloader (fastboot mode). so at every time you should be able to install a custom recovery via fastboot flash recovery recovery.img. if you are in recovery mode with a working recovery, you can do a factory reset (reflash the system, root,... partitions from a protected image) and reboot your device. alternatively you can do a factory reset in fastboot mode.

note: if you erased everything, your recovery will freeze like if you pull off the hard drive from a running Linux. also there are partitions, you are never able to flash, as example the RADIO partition, fastboot or the one, containing the factory reset data. (RADIO partitions contains fine tuned configuration and management of the gprs, lte,... modem)

|improve this answer|||||
  • What's most interesting to me now is, if I powered off now without loading another image, would I still be able to boot into ClockworkMod? From how I understand your answer that should be possible. Also, is it impossible to ruin fastboot? – stacked_deck Aug 13 '15 at 12:23
  • as I said, it should not be possible to ruin fastboot (if you unlocked the device via the proprietary way, the way, the hardware provider expected from you). – Schwertspize Aug 13 '15 at 12:47
  • Alright, I rebooted and had to take out the battery afterwards (stuck with the Google Logo). Holding down VolUp+VolDown while powering on got me into the menu to select Recovery and my ClockwordMod is working. – stacked_deck Aug 13 '15 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.