1

My phone broke while I was in Brazil, so I picked up a Samsung Galaxy S4 GT-I9515 (I9515L for Latin America). When I got back to Canada, I realized that it didn't have the AWS band (1700/2100) enabled, so I couldn't use it with Wind Mobile. Wind Mobile in Canada uses roughly the same bands as T-Mobile in US.

When I search for networks, I only see "Wind Away". On my other phone, I see "Wind Home" as I expect.

From my reading, GT-I9515 is supposed to have the same hardware as GT-I9505 except for the touch screen driver. I can find other GT-I9515L phones for sale on Amazon with the AWS band enabled.

Details:

Model number: GT-I9515L
Android version: 4.4.2
Baseband: I9515LUBU1ANJ1
AP: I9515LUBU1ANJ1
CP: I9515LUBU1ANJ1
CSC: I9515LZTO1ANJ1
Kernel version: 3.4.0-2953991 dpi@SWDD5101 #1
Build number: KOT49HI9515LUBU1ANJ1

Idea 1: Reconfigure Qualcomm modem using QPST and QNC backup

Enable AWS on Samsung Galaxy IV AT&T i337 & Canadian i337M says that AWS can be enabled on other Galaxy S4 models (not I9515) by using the QPST utility to restore a QNC configuration.

I successfully installed Samsung Kies, the phone drivers, and QPST. Taking a QNC backup worked, but restoring the supplied QNC file did not work.

It failed at 5% with "Received an invalid command from the phone" error. The phone continued to function otherwise, but the AWS band did not become available.

Is there a known good QNC configuration for GT-I9515L?

Idea 2: Reconfigure bands in NV_RF_BC_CONFIG_I

Enable AWS for i337 newer roms (nj4) 4.4.4 says that AWS can be enabled by flipping bits in line 1877 (NV_RF_BC_CONFIG_I).

It requires root, and I was able to successfully root the phone by following [GT-I9505 + GT-I9505G] CF-Auto-Root and applying the CF-Auto-Root-jflte-jfltexx-gti9505.zip file for the GT-I9505 model.

Initial values on the phone:

441 NV_BAND_PREF_I      65535
1877 NV_RF_BC_CONFIG_I 562950035735424

I used the mzTool utility mentioned in Unlock all bands of your Qualcomm device to generate the following values and apply them using RF NV Item Manager utility.

441 NV_BAND_PREF_I      896
1877 NV_RF_BC_CONFIG_I 1688849976132480

After applying the values, I used Terminal Emulator on the phone to run these two commands:

su
setprop persist.usb.eng 0

After rebooting the phone, I continued to see my new values in RF NV Item Manager, but the phone still didn't see the "Wind Home" network on the AWS band.

Do I need to do anything else or change any other fields to enable the AWS band through this method?

Idea 3: Install new baseband/hybrid modem on the phone

The answer to Frequency band modifications for Samsung Galaxy S4 says that I can enable the AWS band by flashing a new baseband or hybrid modem onto the phone.

I tried flashing a few hybrid modems using Odin3, but all of them failed to flash. The error was a Fail! (AUTH) message in Odin3.

Is there a known good hybrid modem for this phone that works with the AWS band?

Idea 4: Install a new firmware

I tried flashing the United Kingdom firmware for GT-I9515, but it didn't work.

There are some firmwares for GT-I9515L, but none specific to United States or Canada. Flashing the phone with the Trinidad and Tobago firmware updated the phone to Android 5.0.1, but still doesn't show the "Wind Home" network on the AWS band.

The baseband is now I9515LUBU1BOF1, but I'm happy to revert to the original Brazil firmware if required.

How can I successfully enable the AWS band on Galaxy S4 GT-I9515L?

Idea 5: ServiceMode

Based on Loreno's comment, How To Unlock Samsung Galaxy S4, and How To Make Your Android Perform Dog Tricks, I did the following:

  1. Enter *#0011# in the dialer to automatically open ServiceMode
  2. In ServiceMode, Menu > "Back"
  3. Menu > Key Input > Q0
  4. Wait a couple seconds. If nothing comes up, do Menu Back and Menu Key Input again.
  5. With luck, the following menu is now displayed:

    MAIN MENU
    [1] UMTS
    [2] CDMA
    [3] LTE
    [4] SIM - Not Used
    [5] DOCOMO DEBUG SCREEN
    [6] run EFS SYNC()
    [7] DEBUG SCREEN
    
  6. Choose 1 UMTS

  7. Choose 1 DEBUG SCREEN
  8. Choose 6 PHONE CONTROL
  9. Choose the Network option that's not LOCK
  10. Choose the GSM menu
  11. At this point I see this menu at GSM bands. AWS (1700) is not on it:

    [1] GSM 850
    [2] GSM 900
    [3] GSM 1800
    [4] GSM 1900
    [5] GSM 850/1900
    [6] GSM 900/1800
    [7] GSM ALL
    

1700/AWS also doesn't show up under WCDMA or LTE.

Is there a way to make 1700 or AWS show up in the ServiceMode menu?

  • 1
    Try to change it in the service menu. Open the dialer, enter *#27663368378#. Then UMTS, Debug, Phone, Network, Band, AWS. – Loreno Heer Aug 25 '15 at 21:11
  • @LorenoHeer Good idea. Unfortunately, the 1700/AWS band doesn't show up for me in the ServiceMode menus. I've added details to the question. – Leons Aug 26 '15 at 23:58
1

Idea 1: Reconfigure Qualcomm modem using QPST and QNC backup

I was able to do this method, but LTE B4 (1700/2100 AWS still does not appear) I downgraded to 4.2.2 to complete the 337_AWS restoration

Pude hacer este método, pero LTE B4 (1700/2100 AWS sigue sin aparecer) hice un downgrade a 4.2.2 para completar la restauracion de 337_AWS saludos desde argentina

  • I'm glad it worked for you – Leons Jan 16 '17 at 20:10
  • not worked for me.. just made the metod one, but LTE B4 (1700/2100 AWS still does not appear) – martin fernandez Feb 13 '17 at 2:57
-1

"Received an invalid command from the phone"is anyone find the solution? REMOVE IMEI FROM QCN AND THEN FLASH IT WILL SOLVE THE ISSUE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.