3

My Nexus 5 stated acting strange in the past few days.

Here's the short history:

  • A few days ago, I was prompted to install a new version in OTA update. Done.
  • Yesterday, phone shut off just like that by itself. When powered on, it has a message on a black screen saying "optimizing app x/150". When it was done, phone booted.
  • This morning: wanted to access Google Now, but it wasn't there - I couldn't flick to the left. Was prompted to 'reactivate' google Now, which I did. I should mention it was there after the OTA update.

Since then, every few seconds, and pretty much whatever I try to do, the error message in the title pops up. (side note: strangely, it says Google App and not Apps). Extremely hard to use the phone when every few seconds this pops up. Help, anyone? Thanks!

  • Try clearing cache for those apps in Settings › Apps. If the permanent pop-ups don't let you do that, try the same from safe-mode. – Izzy Aug 18 '15 at 9:08
  • Thanks for the reply. This thing is, I don't know which app to clear the cache to. It just says the generic "Google App". I tried clearing the cache via Android Assistant, but the problem persists. – Optimesh Aug 19 '15 at 6:40
  • I'd say the "Google App" is the app named "Google" (no kidding: there's such one in my app drawer – but I indeed cannot find it in Settings › Apps). Just tried the one from the drawer, brings me to Google Now. Going by the icon, the corresponding app in Settings must be Google Search – which makes sense considering Google Now is part of that. // Using "small atomics": You can clear all app caches at once by booting into recovery and "wipe cache". No data lost that way. – Izzy Aug 19 '15 at 11:40
  • Update: I deactivates Now and Cards from Google Settings (not the general settings, which is probably something that confused me), and this problem was resolved (at the price of losing Now). – Optimesh Aug 20 '15 at 17:00
  • Thanks for the feedback, Optimesh! As this at least solved the issue, I made it an answer. I also included some additional details, so maybe you can bring back that "lost functionality" if you need it. Good luck! – Izzy Aug 20 '15 at 18:38
1

As it says "Google App", it's most likely the app named Google (no kidding: there's such one, just follow the link – though I cannot find it in Settings › Apps by that name). Just tried the one from the drawer, brings me to Google Now – which again matches the app you've got trouble with, as your question states: "wanted to access Google Now, but it wasn't there".

Going by the icon, the corresponding app in Settings must be Google Search – which again makes sense considering Google Now is part of that.

So I'd suggest you try to go there (in Settings › Apps) and clear it's cache. If that doesn't help, try clearing its data as well (same place). If that doesn't solve it, open the Google Settings app (not the general device settings, but the settings app with the "g" for "Google" in its icon – you can find it in the app drawer) and deactivate Now and Cards there. This disables Google Now, but solves the issue (as you've proven).

Hint in case you cannot reach out to Settings or the Google Settings app (e.g. if that pop-up reappears faster than you can tap somewhere else): You can clear all app caches at once by booting to and "wipe cache". No data lost that way. Another good hint in this context is : if the troublemaker is a user-app, it won't be started here, so you can clear cache/delete data/deactivate/uninstall such an app from there.

  • Just to clarify, the Now app appears under "Google Settings" and not the general settings app. – Optimesh Aug 25 '15 at 2:38
  • That might be, but Now is part of Search AFAIK. Btw: As this solved your issue, consider ticking the check-mark next to the answer to indicate such – which then helps others with this problem identifying working solutions :) – Izzy Aug 25 '15 at 8:05
  • Yea I want to do so but I feel the information needs to be complete. I've spent a lot of time looking for the app at the wrong place. It can get confusing between Settings and Google Settings. The latter is where the solution lies. I feel like the answer should reflect that. – Optimesh Aug 25 '15 at 19:32
  • So what do you miss in there that I should add? It's already more complete than the hints I gave in the comments which lead to your solving the issue :) That the Now app appears in Google Settings is not related to your issue as far as I see it. Lots of Google stuff appears in their settings app, logically :) – Oh, reading the comments again (reflecting your latest now) it seems I slightly misunderstood you. Please check back in 2 minutes, I'll update my answer :) – Izzy Aug 25 '15 at 19:35
1

The solutions posted so far failed to fix the problem for me, so I looked at the system log (adb logcat) and saw this error immediately after seeing the popup message:

F/libc (23416): Fatal signal 4 (SIGILL) at 0x5d7ca8f4 (code=1), thread 23528 (HotwordDetector)

I finally resolved the problem in Google Settings → Search & Now → Voice → "Ok Google" detection, where I disabled "From the Google app."

You may see a different "logcat" error than the above, but hopefully your specific error message will lead you closer to the answer.

-1

Go to the app store and uninstall the updates. Then open the app without updating. Fixed mine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.