7

ad-type.google.com is appearing regularly whenever I access the web through Chrome. It's a new adware and there are no solutions available other than

Go to system Settings > Applications > Chrome > Clear cache

But this seems to be not working. After few minutes, it appears again in few devices, we can't uninstall the browser in Nexus devices. Factory reset also doesn't work according to few of them who tried

Related link on Google product forum.

  • Based on a thread on Android Central forum, disable JavaScript for temporary solution. Also, it might the case that not only your device, but your router is affected too. Will research more about it. – Andrew T. Aug 25 '15 at 9:49
  • 1
    Also, some info on Avast forum... probably changing DNS might help. – Andrew T. Aug 25 '15 at 9:55
7

ad-type.google.com redirect adware has been most stubborn malware on the internet now.

Step 1: Disable JavaScript in all your browsers

Step 2: Install Malwarebytes Anti-malware for android

This should inhibit the infection. If Problem persists go ahead with next step

Step 3: Your router might be infected too.
Ask your ISP(internet service provider) to change your DNS server settings.

Also see protect your phone from infecting

  • changing DNS server settings possible with 3g/4g/3g ? – LOG_TAG Aug 25 '15 at 15:03
  • @LOG_TAG you have redirecting virus when using wifi or mobiledata? – Manubhargav Aug 25 '15 at 15:04
  • @LOG_TAG you can change DNS settings in 3G/4G using OverrideDns app. Your device should be rooted though. – Manubhargav Aug 25 '15 at 16:53
  • 1
    @LOG_TAG there;'s no solution for mobile data yet, as for WiFi you can use OverrideDns app but needs root access – Manubhargav Sep 13 '15 at 10:56
  • 1
    Thanks for the info, what I did is downgraded to kitkat and upgraded to Nexus 5 android M image, now it's working fine. I'm not sure it's a right solution – LOG_TAG Sep 13 '15 at 15:23
2

There is host file in /system/etc/ Folder. You need ROOT access.

  1. Just go to host file using root browser.

  2. Open it with text editor.

  3. Write following code : ad-type.google.com 74.125.224.72

You will now go to google.com PAGE.

  • while using wifi it's loading fine!! when I switch from wifi to 3g adware popups redirects , any reason? – LOG_TAG Aug 25 '15 at 11:18
  • I can't root my device, any chance wait for google chrome update will work?? – LOG_TAG Aug 25 '15 at 11:21
  • Currently this is the solution i know. If you solve it let us know! – Saif-RX Aug 25 '15 at 12:18
2

Adbock for non-rooted devices Adfree for rooted devices

The two above adblockers should help you block the ads, but they can't fix the problem for you. You'll need to root your phone and follow the answer from Saif-RX that is at the top of the page.

2

Faced the same issue for the past one week. Have tried the below

  • Installed AV and ran scan. nothing helped. [Didnt Help]
  • Cleared Chrome cache [Didnt Help]
  • Disabled Javascript. it worked but few contents were missing in the webpages. [Partially worked]

Was about to factory reset the phone but did one last thing which helped.

Settings-> Storage -> Cached Data. Cleared this and the problem is resolved.

Try this. This should work. Worked for me :).. Hope this helps

0

This website is responsible for the browser redirection (http://www.onclickads.net/) You need to block it in order to stop the malware that redirects your browser

I blocked it in my home router and since then when i am on that wifi, i get no redirections

0

If you are using UC browset go to Browser setting-----> clear records ----> clear all record It will definately help.

Not the answer you're looking for? Browse other questions tagged or ask your own question.