7

I'm trying to delete contacts from my Google account that's synced with my Nexus 5. It's synced as a Google account, not using Gmail IMAP or anything like that, but all of the contacts display this message when I try to delete them:

You can't delete contacts from read-only accounts, but you can hide them
in your contacts lists.

I don't understand why the Contacts app (default, from Google) is saying my Google account contacts are read-only. How do I correct this problem so I can fully edit contacts from my phone?

  • Tried both the proposed solutions, yet it still get the same warning. In the end I deleted unwanted contacts via the Contacts interface within desktop Gmail. – Rob May 12 '16 at 9:11
  • In case, this happen when add contacts wia others application, like whatsapp. The only way I found to delete this is going to contacts.google.com from some PC/laptop – Cesardl Aug 9 '16 at 21:45
3

Have you tried going into the Apps list (the All tab) and clearing data for Contacts and Contacts Storage?

Once that's done you can resync your phone with Google to get all of your original contacts back.

  • 2
    Mohammed your advice made me delete all my contacts – user168348 May 31 '16 at 18:52
0

^ What he said!

However, I had to CLEAR and STOP both Contacts and Contacts-Storage.

  1. Goto settings: Apps
  2. Goto ALL TAB
  3. Open: contacts: Clear-data, Clear-Cache, Force-stop
  4. Open: Contacts-Storage: Clear-data, Clear-Cache, Force-stop
  5. Goto settings: Accounts
  6. Open: Google: Select (your) account
  7. Select: Contacts: Toggle on/off (force sync)
  8. You may have to force sync twice
  9. Open your contacts app
  10. Only contacts from Google-Contacts should be there
  11. If not, you may have other contact accounts, or contacts stored on phone

Thanks!

In addition to this, being a Verizon customer I had to go into Accounts and disable the "Cloud" account. Then I was able to delete contacts properly from the App. I believe the Cloud account is via Verizon and NOT Google which is where I rely on my backups/syncing to take place. Great help otherwise. Thanks.

protected by Community Jun 30 '16 at 2:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.