1

I was using Freedom app and then one day Google Play Store stopped working in my device. It says "No connection" now.

I have done everything I could,

  • I uninstalled Freedom app
  • Force stopped Google Play
  • Cleared data & cache
  • Factory reset my phone too.

Nothing seems to work. How do I fix this issue?

  • Freedom, from what I know, can actually FIX this. Reinstall it, activate it, and see what happens. – Dan Brown Aug 28 '15 at 9:14
3

Since your phone is obviously rooted just install ES File Explorer (maybe you can do it with others but I know for sure you can do it with this). If you can't download it just get the apk and put it on your phone through your computer. If you factory reset your phone you'll probably have to install SuperSU again as well.

  1. Enable root explorer in ES (you can find it in the bottom of the hamburger slide out here):

    (Click image to enlarge)

    IMG:

  2. Then go to /system/etc and open the file called hosts here. Just tap it and choose open as Text > ES Note Editor.

    IMG:

  3. Then tap the three dot menu on the right, choose edit, and delete everything except 127.0.0.1 localhost.

    Basically make it look like this:

    IMG:

  4. Save, reboot your phone and it should work again.

The hosts file is basically a file that specifies all the addresses that your phone will not connect to at any cost. Freedom adds the addresses for Google Play to this list because it doesn't want your phone to verify your 'purchases' with Google Play. So removing the addresses for Google Play from the hosts file fixes your problem.

  • Any root file explorer will do, of course. – Dan Brown Aug 28 '15 at 9:15
0

I suggest you to download Root Explorer which is the best app. Just follow these steps:

  1. Download and Install Root Explorer
  2. Open it and search for etc/host
  3. Long press on host file and click on open in text editor
  4. Now just add # in 2nd line (Note :- Add # in starting of the line)
  5. Just click on option and save it.

Now you won't face any problems.

0

I had the same issue. After seeing your post a light bulb turned on because I was using Freedom too. I went in the app, opened the settings and pressed stop. I didn't even need to uninstall and Google Play is good as new.

0

All the answers above are 100% correct, However none explain why this happens, You are getting that error basically because you started freedom, while freedom was still installed you could have fixed it by opening freedom -> tapping the 3 dots -> and tapping on STOP. this would instantly solve the problem, but because you uninstalled freedom before you stopped it, doing this means you changed your local host ip(this is what enables freedom to work) and then you never changed it back and uninstalled the app that allows you to revert the change...this is why you now have to go and edit hosts files in the the etc folder.

0

The essential is to stop Freedom's proxy. There are many ways to do so. Since you've been using Freedom for a while, I deduce that your phone is already rooted.

1. Let Freedom stop itself (recommended)

A

Open Freedom, tap the three dots on the top-right corner and tap Stop as in the picture shown above.

2. Manually revert Freedom's changes to system files

2.1 User-friendly approach

Use a root file explorer like Root Explorer or ES File Explorer. Grant it root access and navigate to /system/etc. Open hosts and delete this line (where an asterisk means "anything"):

***.***.***.*** android.clients.google.com

A

And save. Now you're done.

Of course you can simply delete everything except 127.0.0.1 localhost for convenience, but the above line is the only thing you need to delete.

2.2 With (s)hell commands

Just the same essential thing. Open a terminal or an adb shell, then run

    su
    mount -o rw,remount /system
    sed '/android\.clients\.google\.com/d' /system/etc/hosts > /data/tmp/hosts.tmp
    cat /data/tmp/hosts.tmp > /system/etc/hosts

3. Version-specific solution (Freedom 1.6.0+ on Android 5.0+)

If you're using Freedom 1.6.0 or up on Android 5.0 or up, simply reboot your device and there'll be no more problems. Freedom started using a new way to modify hosts so that changes no longer persist through reboots.

  • Don't want to reboot? Open a terminal (again) and type

    su
    umount /system/etc/hosts
    rm -f /data/tmp/hosts
    

    If you're using SuperSU as your Superuser manager, supply option -m to su, i.e., type and run

    su -m
    

    instead of a plain su command in the first line.

  • This is a polite upvote request :) – iBug Jan 7 '18 at 10:18
-1

Easier soln ...just disable freecore in freedom and stop the app and your done.😀

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.