2

I've linked this phone to the same PC many times, but since upgrading to lollipop (5.0.2), my phone is not recognized (in adb devices) when I connect.

When I look in "Developer Options", "USB Debugging" is ungrayed when I'm not connected to my PC, and I can toggle it, but when I connect to the PC, it changes to gray. It changes to gray whether it was enabled or not before connecting.

If I choose MTP as my connect type, I do see my phone's file system from my PC, but there's still no "USB Debugging" link.

Trying to follow the directions on http://developer.android.com/tools/extras/oem-usb.html to connect a driver to this device, when the phone is connected, I don't see "Other Devices" in the list under "Device Manager".

My PC is running Windows 7. My carrier (who pushed the upgrade to lollipop) is T-Mobile.

I've already tried: - updating all the software in SDK manager. - installing a driver from the phone's "pc software". - downloading and installing a driver.

This also fails in the same way from one other PC we have at our company that is used to set up very many other phones.

1

I had to connect as a camera (i.e. pick "PTP" from the item in the drop-down menu option you get when a phone is connected) to get the device to show up in Device Manager (it showed up near the top under Android Devices). From that point, it was standard: right click on the entry under Android Devices, select "Update Driver Software", click "Let me pick from a list of device drivers on my computer", then pick "Android ADB Interface" under "Google, Inc." as the manufacturer.

I had previously tried (several times) connecting charge-only and "MTP" and the device didn't show up under Device Manager. It looks like I always need to connect as PTP; MTP and "debug only" still leave my device invisible to adb devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.