After upgrading my ASUS Zenfone 5 to Android Lollipop, I am unable to access HSPA/3G data. In Brazil we have to manually input APN settings, and when I try to do so, I receive the following message (in Portuguese, here tentatively translated into English):

Access point Name settings are not available for this user.

As my phone is rooted, I have tried solutions proposed by this topic and also by this. None gave me results, even provided that I followed every step without any errors or warnings (chmods and chowns were all effective and edits to content://telephony/carriers were persistant). I also tried to re-generate telephony.db file by deleting it (thus forcing Android to populate it again). A factory reset (as suggested here) had no effect as well.

So far I have nothing to celebrate. My only access to internet is Wifi at home and at work. No mobile data access, and I know it is available (this week I had a try with CM12.1 and data connection worked perfectly. Unfortunately had to revert to stock ROM because CM12.1 is still too buggy). No better suggestions came from googling around other sites and forums.

I hope someone can give me some light over this issue, as I should rely on my mobile internet access to perform various things when commuting or away from wifi.

Heads up: the bounty was automatically awarded by this site yet the problem was not solved. Still awaiting a valid response.

Final update: please refer to my answer a the bottom of this page. The problem is (finally!) solved by the latest (v. released by ASUS.

  • 1
    Seems it's a known issue on Zenfone 5. I found 2 suggestions: downgrade the Android version (which might not be the best interest), or follow the SOP for APN Editor. Unfortunately, I don't have either device to test, so could do a favor and let me know if it works?
    – Andrew T.
    Commented Sep 1, 2015 at 4:30
  • @AndrewT. I really do not want to downgrade Android for now (would be last resort). Following the SOP did not work: as I try to launch the installed ApnEditor, I get the message "ApnEditor has stopped" and the app closes itself. Any other ideas? Thanks for your attention!
    – SeuMenezes
    Commented Sep 1, 2015 at 14:06

5 Answers 5


After hours of experimenting, found the reason for this, (it works for me). Nothing too technical about this post in contrast to what these posts suggest.

Step 1 : WiFi turned on, and be in the range of a known WiFi network.
Step 2 : Reboot the phone (may need to reboot several times, if it doesn't work the first time)
Step 3 : When the phone reboots, it should connect to WiFi network.
Step 4 : Go to APN settings and see that you can, now edit APN settings.

Reason : When phone is turned on, if it's not connected to WiFi, it will try and connect to mobile network thus disabling you from editing APN settings. However if you try the above steps, your phone connects to WiFi instead of Mobile-data.

  • 1
    I have tried the steps you provided without any success. WiFi is always turned on here; once I reboot the device, I try and go into apn settings but the item is greyed out from the menu. It takes around 40 seconds to become available, and when I open it, there comes the dreaded message. Apn settings are still unreachable to me.
    – SeuMenezes
    Commented Sep 5, 2015 at 5:20
  • have you tried toggling off mobile data,turning on WiFi and rebooting?
    – Manu
    Commented Sep 5, 2015 at 5:39
  • Yes, I had this idea but the result (or lack thereof) was the same.
    – SeuMenezes
    Commented Sep 5, 2015 at 5:43
  • Try factory reset
    – Manu
    Commented Sep 6, 2015 at 18:45
  • As I pointed in my question (last sentence of second paragraph), I have tried it before (multiple times) without any benefit. Thanks for your attention anyway!
    – SeuMenezes
    Commented Sep 6, 2015 at 23:44

As you have root permissions, try copy and replace telephony related files from CM12.1 to your phone.

/data/data/com.android.providers.telephony/databases/ is the path where telephony.db exists

Note: This may harm your normal working of your phone; try it with your own risk.

  • where can I get these telephony-related files from CM12.1? all I have here are boot.img and system.img for flashing. I wouldn't like to install CM12.1 just to retrieve such files... any repository around where I can download them?
    – SeuMenezes
    Commented Sep 1, 2015 at 14:38
  • you can install CM 12.1 in your PC with Virtual box link and try explore directories of it
    – AndroidDev
    Commented Sep 2, 2015 at 11:09

The latest stock ASUS update (v. solves the problem.

I had to unroot my phone, apply both and downgrades (in this order), then I applied a FOTA upgrade (97Mb download, received and applied automatically). Then I could install the latest version (downloaded from ASUS website; uploaded via USB to phone's internal storage; unplugged USB and then the update could be applied automatically). APNs are available by default, I did not even have to input my APNs manually (as I had to do in prior versions).

  1. Remove your simcard PIN
  2. Turn-Off Data
  3. Turn on wifi
  4. Reset the phone 3 times

That worked for me.


Try manually setting the HSPA network. Open Dialer and dial *#*#4636#*#* and set it manually.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .