I have an HTC Incredible 2. I went to check my alarm clock before I went to sleep last night by pressing the clock on the home screen and nothing happened. It usually opens up my alarm clock.

After pressing several times and nothing happening I went into all apps and clicked the clock app. It said:

The linked program is no longer installed on your phone.

I did not uninstall it. The only unusual activity I did last night was install the 5 Guys app, Opera Mini, uninstall Opera Mini because I did not like it, install Dolphin Browser.

I went into widgets and selected the htc clock and put a different variation on my home screen, it did not work either. I tried to find it on the Android market to reinstall it and its not listed there either.

Is there anything else I can try before I go to my Carrier?

  • Have you turned the device on and off? Can you see the app in the applications manager? If so, can you clear the data and/or cache? – ale Aug 4 '11 at 15:36
  • @AlEverett I have tried turning it off and on. The icon is still there but says the program is no longer installed when you click it. How do you clear the cache? – JD Isaacks Aug 4 '11 at 15:57
  • Settings | Applications | Manage applications | All |<application> – ale Aug 4 '11 at 16:45
  • My alarm clock just started working again today, they must have pushed a new update. – Tester101 Aug 15 '11 at 17:25

I asked Verizon and they said it is because of an update. There are lots of complaints about the same issue and until another update is released there is nothing you can do, not even a factory restore.

| improve this answer | |
  • Was this caused by a Verizon update, or android update? Any word on when the fix will be available? – Tester101 Aug 8 '11 at 19:44
  • @Tester101 From what I was told it is becuase I updated to Android 2.3.3 and I was told htc is working on a fix. – JD Isaacks Aug 8 '11 at 19:50
  • I have the same issue but it just hit me last night for some reason. Is there any word on when the next update will be released? – user7916 Sep 9 '11 at 17:21

There is an over-the-air downloaded today to get alarms back. YEA!

Go to settings > Download updates > Check new

| improve this answer | |
  • 1
    +1 That worked. Wow, I thought I would never get the default alarm back. However, I have been using the app I downloaded for so long now, I think Ill just stick with it. Thanks :) – JD Isaacks Dec 14 '11 at 21:06

Can you get to it from the all apps button in the lower left corner? I've had to remove an app from the home screen and re-add it, although for me it's only been after upgrading it. But if you can get to it from the all apps drawer, then you should be good.

| improve this answer | |
  • When I go to it from the all apps drawer it says: The linked program is no longer installed on your phone. but the icon is still there. – JD Isaacks Aug 4 '11 at 15:18

I have found the same problem, and just figured it out. I luckily have the digital clock on my wallpaper. I tap it and my clock and alarm come up. I can then adjust whatever changes I need.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.