I have a Samsung Galaxy S5 with Lollipop and recently broke my screen so that it is now black. adbcontrol worked somewhat okayish - I did not see the whole screen but it was just enough to navigate to my memos and share them. But now I remembered that I hadn't synced my Browser bookmarks so I started my PC again, connected the phone, adb devices showed the device - but unauthorized. That already happened to me once so I ran adb kill-server && adb start-server but the phone stays unauthorized. Unplugging and putting it back in or restarting the computer did not help either.

Why is it suddenly unauthorized? And why can't I fix it with what I tried - because that worked already a few times... And most importantly: Has anybody got any idea how I could make this work again (or maybe a different screen-replacing tool that doesn't require adb) ?

  • I can't say why you are unauthorized, but you can try resetting all authorisation in developer options. it will ask you again. Commented Sep 2, 2015 at 9:08
  • Thank you, but this is not an option because my Screen doesn't work (since I cannot access it anymore also not with the tool 'adbcontrol') - except I could somehow accept it again by using only the pc (?)
    – lucidbrot
    Commented Sep 2, 2015 at 9:17

1 Answer 1


You can try the following:

  • adb kill-server followed by adb start-server
  • (on device) Settings -> Developer Options -> USB Debugging -- switch off and on
  • [Windows] Make sure you have the proper driver (your best bet is Universal Adb Driver by Koushik Dutta -- will handle any device)
  • [Windows] Try turning off all fancy on-the-fly anti-malware scanners/firewalls
  • [Linux] Make sure you have the proper UDEV rule in /etc/udev/rules.d/51-android.rules (again, universal solution: https://github.com/snowdream/51-android)
  • [Linux] Try using adb as root
  • Restart your phone
  • Replug cable, try different cable, different port, remove any extender cables

I hope somthing works for you :)

  • Thank you :) but I already tried unplugging, restarting and killing the server and re-enabling on the device is impossible cause of destroyed screen...I decided to bring it to a screen-replacement-shop..that should let me keep the data
    – lucidbrot
    Commented Sep 6, 2015 at 10:04
  • You're welcome :). I hope your device works now. Let me know if there is anything that works besides the sceen replacement. Commented Sep 6, 2015 at 10:27
  • Now that the screen works again, adb DEVICES made the device ask me again for permission so youryour idea of dis- and reenabling would probably have worked if the screen would have
    – lucidbrot
    Commented Sep 8, 2015 at 20:03
  • Great! :) Well you can mark it as an answer then :) Commented Sep 9, 2015 at 5:52
  • I just re-read my question and noticed that I mabe didn't make the 'my screen doesn't work' part clear enough. Questions without that exist enough on here. On one hand, your answer didn't help me at all, but on the other hand it is probably the most complete list of what could help when the screen still works. So I guess I give you that tick because ther is probably no solution for my specific problem.
    – lucidbrot
    Commented Sep 9, 2015 at 8:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .