In my new moto E, tethering my internet connection isn't working. I configured my nexus tablet to use my mobile phone connection. Everything looks fine, it looks like it is connected, but I can't access anything.

Using a terminal app, I can successfully ping a domain with numbers: ping, but when I try to point a domain name (Google.com), it fails.

I've tried with other devices and the result is the same.

How do I manually configure the DNS of my tethered connection?

Any other suggestion to fix this problem is welcome.

Some tests that I did:

  • I tested tethering with two android devices, and both had the same problem.
  • These devices used to successfully "theter" in my old Moto G.
  • The problem happens in wifi and usb tethering.
  • A few apps work fine, like WhatsApp. I believe they use the IP Address directly.

The moto E has Android 5.0.2.

1 Answer 1


I've installed the DNSet app and it solved my tethering Moto E bug. The pro version allow you to configure any DNS server, but it wasn't necessary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .