0

[ I first asked this question on stackoverflow by mistake. ]

I have this "old" Lenovo A2107 tablet which I rooted years ago (using a download from http://androidforums.com/threads/a2107-root-mods-and-rom-discussion.661261/, tho running its root.bat script by hand from my GNU/Linux machine) and that worked fine: I could "su" from the shell and then edit all the files I wanted.

Then I passed this tablet to my daughter for a couple years, and now I got it back.

/system/bin/su is still present, still the same date and size, still mode "rwsr-sr-x", still the same firmware (Android 4.0.3) so all looks fine, but when I try to run it from a shell, it just tells me "Permission denied". And of course, other applications that require root bump into the same problem.

Any idea what might be going on? What I could try to do to track it down?

  • 1
    have you tried a root checker app as they can be good to detect a possible issue? – iTechy Sep 2 '15 at 12:50
  • re-root. repeat the procedure that you used first time. that should do the trick. – Iftekhar Sep 2 '15 at 13:05
  • @iTechy: RootChecker just tells me that my machine is not rooted. – Stefan Sep 2 '15 at 13:23
  • 1
    Try adb shell su mount -o remount,rw /system – Bo Lawson Sep 2 '15 at 15:38
  • Then you will need to re root – iTechy Sep 2 '15 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.