I want to connect my LG Optimus 2X (P990) to my PC to use the Internet. I tried using the LG PC Suite 4 available for windows, but it crashes as soon as I make a connection with my phone. And, There's no option in the suite to use the Internet connection from the phone.

Also, I can't get Ubuntu to detect a connection from my phone (both Bluetooth and Data Cable).

Please help me out with this.

Thanks in advance.


EasyTether is the easiest way to share your phone wireless internet with your computer. You install the program on your phone, set up the drivers (which can be found here) and run. To enable easytether, check the top box on the application screen. Easy as that!

After you install the drivers:

For Ubuntu:

  • start a terminal window
  • type easytether connect
  • it will connect, and give you another command that you can type into another terminal window to see status information about your connection.

NOTE: the original terminal window you open (that you typed easytether connect into) must stay open while you are using the connection

For Windows:

  • right click the Easytether logo in the taskbar (lower right hand side, by the clock)
  • choose connect via (big number here)
  • you're connected!
| improve this answer | |
  • mmhmm! glad you got it working :) – jlehenbauer Aug 27 '11 at 21:52

I don't know if this will work with your device, but I used to use Android Wired Tether the couple times I needed to use my phones data connection. It does require root, so I don't know if that is an option for you or not.

| improve this answer | |

it worked out of the box in ubuntu 12.

While installing the deb package, I got the following error message in /var/log/syslog. But, this warning can be ignored.

May 18 22:49:29 dev01 udevd[375]: invalid ENV attribute, 'DRIVER' can not be set /lib/udev/rules.d/65-easytether.rules:1

I had installed easy tether lite application in my android phone following the instructions from the application.

To connect to the phone, I did:

sudar@dev01 /opt/testing/lens/bin $ easytether connect  80A354043043422239
trying legacy service port (this is not an error)
connected as easytether0, wait while network-manager configures it

or run 'sudo dhclient easytether0' if you do not use network-manager

press Ctrl-C when you are done with the connection

The network-manager was able to pick up the device immediately and configured a dhcp address automatically.

easytether0 Link encap:Ethernet  HWaddr 02:00:54:74:68:72  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::54ff:fe74:6872/64 Scope:Link
      RX packets:2163 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3035 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:500 
      RX bytes:1008908 (1.0 MB)  TX bytes:418292 (418.2 KB)

When I check the default route, it was properly setup to the tether device.

sudar@dev01 /opt/testing/lens/bin $ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 easytether0     U     1000   0        0 easytether0   U     1      0        0 easytether0

Overall, it is very easy to get connected. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.