3

Following this week's releases of CyanogenMod, there's finally CM 12 and CM 12.1 releases for the Samsung S4 Mini. Therefore, I upgraded from the latest 11 release to 12.1.

However, after installing, I was unable to access the Play Store, getting "No Connection" and a "Retry" button opening it up. Following instructions from various places, I tried changing the date and resetting it, and then tried removing my Google account from the device. This is where I am now stuck.

Opening the Play Store now, it sits "Checking info...", occasionally telling me "Unfortunately, Google Play services has stopped" (it's been prompting me to upgrade Google Play services ever since I installed CM 12.1, as one would expect, but I've been unable to upgrade it due to lack of access to the Play Store) a variable number of times while doing so. Eventually, I reach a screen telling me:

Can't establish a reliable connection to the server.

This could be a temporary problem or your Android device may not be provisioned for data services. If it continues, call Customer Care.

However, internet access works fine in Chrome and in all non-Google apps. I can load play.google.com almost instantly in Chrome: there's no internet connectivity issue here.

Trying to add my Google Account from settings leads to the same "Checking info..." sequence of screens.

How can I re-add my Google account and regain access to the Play Store?

2

When you flashed from CM 11 to CM 12 or 12.1, did you wipe /data,/system,etc. via recovery? You'd also need GApps for CM 12/12.1 too, as that would include newer Google Play Services that are compatible with 12/12.1.

Generally when you upgrade from a different OS version (CM 11 being Android 4.4, CM 12/12.1 being Android 5.x.x), it is recommended fully wiping everything before flashing to prevent odd issues like you are seeing here.

  • 1
    I follow the system upgrade prompt within CM, never touching Recovery myself. – gsnedders Sep 4 '15 at 13:26
  • 1
    wiki.cyanogenmod.org/w/Updating says to upgrade manually if Google apps are installed. sighs It'd be nice of the CM Updater checked if Gapps were installed and told you to manually update rather than updating then leaving everything broken... – gsnedders Sep 4 '15 at 13:29
  • Gotcha. I do things differently, I go in via custom recovery to wipe everything, then flash the ROM and gapps as needed. I had Google Play Services broken once, as it was using Android 4.4's version instead of Android 5.x's, and Google apps and Play Services were freaking out, constantly asking to upgrade but failing...really odd stuff. – DukeSilversJazz Sep 4 '15 at 13:30
  • 1
    I'm mostly just annoyed about the UI offering to upgrade in a way that the docs say not to when it could easily programmatically check for. <_< – gsnedders Sep 4 '15 at 13:34
  • Am about to install via recovery... – gsnedders Sep 4 '15 at 13:34
0

Using a root explorer app, go to /system/etc, open the file called hostsin a text editor. In the text editor app, edit the file to add # before the next IP address (for example: from 123.4.567.8 to #123.4.567.8). This will comment out a hosts redirection and hence allow you to access the site which was blocked by that hosts redirection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.