1

I recently tried to move several apps from my phone's internal storage to my SD card, however, it proved to be unsuccessful. The "Move to SD card" button was merely grayed out for a while and afterwards nothing had been moved. This happened every single time I tried to move an app, so I restarted my phone. Then something peculiar happened. My phone claimed that my "SD card is blank or has unsupported filesystems". It then gave me an option to format the card, to which I consented. But now, it just tells me again and again that my "SD card is blank or has unsupported filesystems" even though I have formatted it multiple times. I have looked for solutions to this online, and it seems I have to format it on a computer. Well, the thing is, when I plug my phone into my computer the SD card does not show up as it has always done prior to this incident. Also, whenever I try to move apps to my SD card now my phone just tells me "Your phone does not have a SD card. Insert SD card." What is this all about? Is it possible to get this working again? Or do I have to buy a new SD card?

Phone: Samsung Galaxy S4. SD card: SanDisk Ultra microSD 32 GB.

2

Emil! Believe it or not, it's not the problem of your SD card,but your phone. In fact, the crash of our SD cards is not common. Generally speaking, lots of phones have difficulty in loading large memory SD cards. So when you make some abnormal operations, your phone will pop up some warning information. But at this moment, you should stay calm and you shouldn't consent its requirement, or it can not recognize your SD any more. Therefore, you'd better shut down your phone and power on it again. If the phone screen pops up "SD card is blank or has unsupported filesystems", you just tap"No".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.