1

When I woke up this morning, I found my good old Milestone² (aka Droid 2) in what first seemed a boot-loop: Google logo, CM boot animation, off, repeat – with the "off" state lasting a couple of minutes (turned out it already had depleted the battery, and that took a while to recharge). I finally managed getting into recovery, and wiped cache+Dalvik (Android 4.3 on the device).

After letting it charge up to 100%, I tried booting up again, it got stuck in the CM boot animation. Luckily, adb logcat already responded – and I could see the line

D/WifiStateMachine( 1620): VerifyingLinkState what=131155 NOT_HANDLED

repeated every 1..2s for several minutes (stopped watching it then). To get out of that, I tried to turn off Wifi via ADB – but the svc wifi disable command never returned (waited several minutes again, then aborted it with Ctrl-C).

As the above shows, I can get as far as invoking adb shell and getting root access. But I've got no idea what I could do to break through that hanging process. As the GUI is not loaded, I obviously cannot interact with it (neither via keyevents on the shell I assume), so turning airplane mode on via ADB wouldn't do that way.

I cannot tell what might have caused this state: when I put the device in its cradle yesterday, it was working fine. Last thing I did was updating 2 user-apps from Playstore, but they shouldn't have caused network trouble (Password Safe Lite should not be loaded at that stage, and neither should AlarmDroid). Before that, I've replaced BlankStore (a GooglePlayStore alternative for devices not running Google Apps). Though that being a system app, I very much doubt this was the cause – as I see no connection to the logs.

I've put all errors/warnings from Logcat on pastebin, just skipping irrelevant things like PackageManager skipping unknown permissions. Where that pastebin ends, the last message is repeated eternally.


Apart from a : Any ideas what I could try to get the system up again?


Edit: last logcat with wpa_supplicant.conf "made virgin" (i.e. no APNs anymore, just the fresh file from the ROM), no other changes made. The "eternally repeating error" is gone, I'm still stuck in the CM boot logo. The initially wiped Dalvik cache has been rebuild on the previous boot already.

  • 2
    OP already knows it but readers might not be: There seems to be two kind of problems in the error log: 1) APN 2) Wi-Fi. I suppose Wi-Fi is cause of evil here. This answer helps to enable Airplane mode without needing to launch any GUI or input any keyevent. Alternatively, /data/data/com.android.providers.settings/databases/settings.db has the key wifi_on set to 1 when Wi-Fi is turned on. Pull that file using your Recovery, change 1 to 0, push the file back, reboot and see what happens. – Firelord Sep 6 '15 at 18:16
  • 1
    Thanks, @Firelord! I've just replaced the wpa_supplicant.conf with a "virgin" one (from the ROM image), that repeating error is gone. wifi_on was already set to 0 in the database. According to the logs Zygote starts up, the system service is created, and all packages are initialized. Finally, last entry in the log says E/MobileDataStateTracker( 1643): default: Ignoring feature request because could not acquire PhoneService, and that's it. On the screen, I'm still in the boot animation. Tried again with SIM and SD card removed, same thing. – Izzy Sep 6 '15 at 20:35
0

Not a satisfying answer: nothing tried lead to success, so I ended up performing a factory-reset after having removed the replaced system app. It isn't sure that app caused the issue, but that was the only change to the system itself applied shortly before – so better play it safe.

That brought the device "back to live" (checked for several weeks to make sure – before updating to the latest CM available for it, which brought it up to 4.4.4 Kitkat).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.