3

I'm currently trying to root my Samsung Galaxy S4 Mini, so to install CWM, I boot the device into download mode using my Linux Mint 17.2 laptop:

$ adb reboot bootloader

Now, as intended, my phone boots into download mode, yet fastboot doesn't recognize the device:

$ sudo fastboot devices
$ sudo fastboot continue
< waiting for device >

However, in lsusb, the phone clearly shows up:

Bus 001 Device 005: ID 04e8:685d Samsung Electronics Co., Ltd GT-I9100 Phone [Galaxy S II] (Download mode)

As you can see above, I run fastboot as root, so it certainly isn't a permission problem.

I can't find a solution anywhere on the internet, so any help is appreciated. If you need any further information, let me know.


Let me throw some additional stuff on you, in case it helps:

My PC:

$ dpkg -s android-tools-fastboot
Package: android-tools-fastboot
Status: install ok installed
Priority: extra
Section: devel
Installed-Size: 154
Maintainer: Ubuntu Developers <[email protected]>
Architecture: amd64
Source: android-tools
Version: 4.2.2+git20130218-3ubuntu23
Depends: libc6 (>= 2.14), libselinux1 (>= 2.0.65), zlib1g (>= 1:1.2.3.4)
Conffiles:
 /etc/bash_completion.d/fastboot df71a6a847b1d7c6499ad718502b651f
Description: Android Fastboot protocol CLI tool
 Fastboot is a diagnostic protocol primarily used to update the flash
 filesystem of Android devices over USB.
 .
 This package provides the fastboot command-line tool.
Homepage: http://developer.android.com/guide/developing/tools/adb.html
Original-Maintainer: Laszlo Boszormenyi (GCS) <[email protected]>

$ uname -a
Linux dracarys 3.16.0-38-generic #52~14.04.1-Ubuntu SMP Fri May 8 09:43:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

My phone:

Samsung Galaxy S4 Mini GT-I9195
Android 4.4.2
Linux version: 3.4.0-3173303
2
  • did you set up udev rules? Sep 6, 2015 at 20:42
  • All udev rules I found online only changed permissions, which is circumvented by executing fastboot as root. I did, however, try various of those rules, although I don't recall which I tried.
    – s3lph
    Sep 6, 2015 at 21:40

1 Answer 1

1

Samsung devices do not support fastboot. To flash a custom recovery, you can either use the dd command from within your ROM (assuming you're rooted), or use Heimdall. Instructions on using Heimdall can be found in the Heimdall Linux README.

3
  • 1
    I want to flash CWM in order to root my device... so it seems that Heimdall is the only option? Is there any specific reason that fastboot isn't supported on Samsung devices other than Samsung being mean to its power users?
    – s3lph
    Sep 7, 2015 at 4:00
  • I managed to flash CWM recovery successfully, although the command line tool is much more user friendly than the frontend: sudo heimdall flash --RECOVERY recovery.img.
    – s3lph
    Sep 7, 2015 at 6:19
  • There doesn't really seem to be a reason, it's just Samsung.
    – keepcalm
    Sep 8, 2015 at 2:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .