2

Hello everybody I face annoying error when, whenever I try to install this app I face many errors. Ok, per usual, I tried installing it through Google Play store but whenever I do so I get this error:

error: Package File is Invalid

Ok, doing a bit of research into this error, most people have stated that it is usually a Google Play Error so I did the usual (Open Google Play Store, clear the cache & data and if fails then uninstall the app & updates, clear the Google Play framework data & cache and all other apps related to it) and no luck. I have also done this several times as well!

Ok seeing as that failed, I then decided to install apk outside of Google play store - so I got the latest apk online and proceeded to install it on my phone - installing then I got THIS message:

Application Not Installed

I couldn't believe that didn't work, then I researched into what could be causing this error (ROM, Cache, Checking Space, Maybe Even The App) so yet again I did the usual (I re-downloaded the app several times, used such apps as Root Explorer, Astro and ES File Manager to install it, clear the cache partition from boot and just check to see if the unknown sources is checked) but no luck.

I then tried to install the App via ADB and I just face even more errors.

I tried:

C:\Users\Support\AppData\Local\Android\android-sdk\platform-tools>adb install C:/com.appnana.android.giftcardrewards.apk

and got:

Failure [INSTALL_FAILED_DEXOPT] rm failed for -f, Read-only file system

Researched this and got no solution so I tried going around the method:

adb install -r

Got the same error:

Failure [INSTALL_FAILED_DEXOPT] rm failed for -f, Read-only file system

Guessing it was a read-only problem I searched for a way to rectify this:

adb shell sysrw Got

sysrw: permission denied

Even tried:

adb root

And Got:

adbd cannot run as root in production builds

I couldn’t find an answer to doing this so I tried doing other miscellaneous solutions:

Tried adb shell | su | mount -o rw,remount /system line by line and got:

Usage: mount [-r] [-w] [-o options] [-t type] device directory

Tried on my phone mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system and got

mount: not permitted

Tried adb remount and got:

remount failed: Operation not permitted

Even Tried as a way to beat this permission denied error adb shell whoami and got:

whoami: permission denied

I looked at super user with all permissions set to automatically grant before I did all of this, and I noticed that some of the permissions in the Super User where in red (more specifically red -rwsr xr x) and tried to update the Su binaries but wouldn’t let me so I went to SuperSU, and it deleted the SuperUser app, updated its self, updated the app and updated the binaries but still no luck!!!

I thought it might be the SD Card so I switched SD Cards, backed up the data then formatted the SD Card by the phone since phones can be funny on FAT32 partitions if it was not partitioned by the phone and still no luck. Even tried Market Helper which worked on other apps which were way of Android 2.3 limitations but I still got the Package File is invalid error.

What could be wrong??? I installed the latest Java SDK with the latest ADB from Google. I installed the Samsung drivers and I have no luck. I cannot remember what tutorial I followed but root appears to be working fine. My phone is Samsung Galaxy Y S-5360 and I still have the official 2.3.6 interface and I don't want to change that. Even when I install it on the online version of the app store I get error 906, what could be wrong? The documentation of the app even says it supports 2.3 and upwards. Even if it could be the app that’s the problem I still need to sort out this ADB for important future use. Please help and a step by step guide would be greatly appreciated so much – I worked really hard on this app and I want to continue to do so, and your help would be greatly appreciated. I don’t mind doing whatever you suggest as long as I don’t lose my app layout and app data (unless you have a software which could back all of that up.)

Thank you so much

D

PS. When I type devices on ADB is shows my device as 0123456789ABCDEF, is that unusual, I felt there should be more of a unique code to my phone than... that. Thank you :D

  • 012345...... is not unusual. Also have you tried _ adb shell_ and then _ su_ . Also try to update to latest busybox and try both superuser and supersu binaries. – Iftekhar Sep 7 '15 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.