How do I fix “Failed to sync vcpu reg” error? does not help. I tried all the solutions I could for Mac on the post but none worked.

I started a new project and tried to run the emulator, but I get these errors:

HAXM is working and emulator runs in fast virt mode
emulator: Failed to sync vcpu reg
emulator: Failed to sync HAX vcpu context

It used to work yesterday. I didn't change/download anything.

Why did it stop working? I also made sure there are no other processes of the emulator running.

I'm running Android Studio in OS X Yosemite.

  • Are you using any VM's running in your Mac? Please stop and check if any running. Also look into this SO post. It says you can restart the computer and start the emulator first before running any other programs. Let me know if it works.
    – Lucky
    Sep 12, 2015 at 7:55

3 Answers 3


Make sure that you're not running any other virtual machines, then try again.

I was running a guest Windows 8 VirtualBox on El Capitan and I got the same error when I tried to run a virtual Android device in Android Studio. I shutdown the guest OS and VirtualBox then my AVD booted up.


In my case, it's the docker program conflict with AVD, quit docker then restart the AVD is ok.


According to Google Issue Tracker #37076131 - [Emulator] HAXM ioctl failed on Mac when trying to restore vcpu state,

Considering the bug fixed: HAXM 6.1.1 (available as a part of Android Studio or on Intel website at https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager76 ) is designed to coexist with Docker/VirtualBox/HVF hypervisors on Mac OS

Install latest version https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager and it works

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .